summaryrefslogtreecommitdiffstats
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorThomas Graf <tgraf@suug.ch>2010-10-19 11:06:42 (GMT)
committerThomas Graf <tgraf@suug.ch>2010-10-19 11:06:42 (GMT)
commitc0cd587dfc46ca8e8e5f9da51e878e0678950f23 (patch)
tree10aaa6c61ac3416f2fd579c3d05c9210c7d4ef83 /lib/Makefile.am
parent3229b32e39363c439f0d042b561417e7b48aa786 (diff)
downloadlibnl-c0cd587dfc46ca8e8e5f9da51e878e0678950f23.zip
libnl-c0cd587dfc46ca8e8e5f9da51e878e0678950f23.tar.gz
libnl-c0cd587dfc46ca8e8e5f9da51e878e0678950f23.tar.bz2
nl-qdisc-add tool
Adds a cli based tool to add/update/replace qdiscs. This tool requires each qdisc to be supported via a dynamic loadable module in pkglibdir/cli/qdisc/$name.so. So far HTB and blackhole have been implemented. Syntax: nl-qdisc-add --dev eth2 --parent root --id 1: htb --r2q=5 nl-qdisc-add --update-only --dev eth2 --id 1: htb --r2q=10
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index ba64a99..afb08ea 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -52,3 +52,13 @@ libnl_route_la_SOURCES = \
fib_lookup/lookup.c fib_lookup/request.c \
\
route/pktloc_syntax.c route/pktloc_grammar.c route/pktloc.c
+
+
+if ENABLE_CLI
+nobase_pkglib_LTLIBRARIES = \
+ cli/qdisc/htb.la \
+ cli/qdisc/blackhole.la
+
+cli_qdisc_htb_la_LDFLAGS = -module -version-info 0:0:0
+cli_qdisc_blackhole_la_LDFLAGS = -module -version-info 0:0:0
+endif