summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorThomas Graf <tgraf@suug.ch>2010-10-20 12:57:39 (GMT)
committerThomas Graf <tgraf@suug.ch>2010-10-20 12:57:39 (GMT)
commit27883b0f9b0da6bb33ccc185107a2870df25d030 (patch)
treefbda57a6026fbc6653648ecb9d588d2d9e938b5e /src/Makefile.am
parent18848090f99cae37ac1a3052369ab4d26ed9ada0 (diff)
downloadlibnl-27883b0f9b0da6bb33ccc185107a2870df25d030.zip
libnl-27883b0f9b0da6bb33ccc185107a2870df25d030.tar.gz
libnl-27883b0f9b0da6bb33ccc185107a2870df25d030.tar.bz2
nl-class-add tool
Adds a cli based tool to add/update traffic classes. This tool requires each class to be supported via the respetive qdisc module in pkglibdir/cli/qdisc/$name.so. Syntax: nl-class-add --dev eth2 --parent 1: --id 1:1 htb --rate 100mbit nl-class-add --update --dev eth2 --id 1:1 htb --rate 200mbit
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 4a7f98f..1a6f080 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -7,6 +7,7 @@ AM_LDFLAGS = -L${top_builddir}/lib -L${top_builddir}/src/lib -lnl-cli
sbin_PROGRAMS = \
nl-qdisc-add \
+ nl-class-add \
nl-classid-lookup
noinst_PROGRAMS = \
@@ -77,6 +78,9 @@ nl_qdisc_delete_LDADD = -lnl-route
nl_qdisc_list_SOURCES = nl-qdisc-list.c
nl_qdisc_list_LDADD = -lnl-route
+nl_class_add_SOURCES = nl-class-add.c
+nl_class_add_LDADD = -lnl-route
+
nl_route_add_SOURCES = nl-route-add.c
nl_route_add_LDADD = -lnl-route
nl_route_delete_SOURCES = nl-route-delete.c