summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorThomas Graf <tgraf@suug.ch>2010-10-26 23:21:50 (GMT)
committerThomas Graf <tgraf@suug.ch>2010-10-26 23:21:50 (GMT)
commit65e386c8ba490d405f539322a12e1f1c7ea2eb5c (patch)
tree155a0dafacd32619123042f926a8d1638b28ed8b /src/Makefile.am
parentb57a697ef1053a70264e9bedea3d2b98b8b24019 (diff)
downloadlibnl-65e386c8ba490d405f539322a12e1f1c7ea2eb5c.zip
libnl-65e386c8ba490d405f539322a12e1f1c7ea2eb5c.tar.gz
libnl-65e386c8ba490d405f539322a12e1f1c7ea2eb5c.tar.bz2
Packet location updates
This patch includes various bugfixes in the packet location parser. Namely it removes two memory leaks if parsing fails. The parser is correctly quit if an allocation error occurs and it is no longer possible to add duplicates. It removes the possibility to differ between net and host byteorder. This is better done in the actual classifiers as it makes more sense to specify this together with the value to compare against. The patch also extends the API to add new packet locations via rtnl_pktloc_add(). It introduces reference counting, therefore you now have to give back packet locations with rtnl_pktloc_put() after looking them up with rtnl_pktloc_lookup(). But you are allowed to keep using them if the packet location file has been reread. The packet location file now also understands "eth", "ip", and "tcp" for "link", "net", and "transport". A --list option has been added to nl-pktloc-lookup to list all packet location definitions A --u32=VALUE option has been added to let nl-pktloc-lookup print the definition in iproute2's u32 selector style. A manual page has been written for nl-pktloc-lookup. Finally, nl-pktloc-lookup has been made installable.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 6ea3fee..895c8ae 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -9,7 +9,8 @@ sbin_PROGRAMS = \
nl-qdisc-add nl-qdisc-list nl-qdisc-delete \
nl-class-add nl-class-list nl-class-delete \
nl-cls-add nl-cls-list nl-cls-delete \
- nl-classid-lookup
+ nl-classid-lookup \
+ nl-pktloc-lookup
noinst_PROGRAMS = \
genl-ctrl-list \
@@ -25,8 +26,7 @@ noinst_PROGRAMS = \
nl-route-add nl-route-delete nl-route-get nl-route-list \
nl-fib-lookup \
nl-list-caches nl-list-sockets \
- nl-util-addr \
- nl-pktloc-lookup
+ nl-util-addr
genl_ctrl_list_SOURCES = genl-ctrl-list.c
genl_ctrl_list_LDADD = -lnl-genl -lnl-route