summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorThomas Graf <tgraf@suug.ch>2010-10-19 14:31:23 (GMT)
committerThomas Graf <tgraf@suug.ch>2010-10-19 14:31:23 (GMT)
commit757592ec1b1d3c70a325ae997adb94009589c5a6 (patch)
tree40aabb22d05207a6e07a7a05f6d034dc06a0f038 /src/Makefile.am
parentfa89403149a59ed18015713f517a5cc9356caffd (diff)
downloadlibnl-757592ec1b1d3c70a325ae997adb94009589c5a6.zip
libnl-757592ec1b1d3c70a325ae997adb94009589c5a6.tar.gz
libnl-757592ec1b1d3c70a325ae997adb94009589c5a6.tar.bz2
classid database
A database to resolve qdisc/class names to classid values and vice versa. The function rtnl_tc_handle2str() and rtnl_tc_str2handle() will resolve names automatically. A CLI based tool nl-classid-lookup is provided to integrate the database into existing iproute2 scripts.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 5144bb4..4a7f98f 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -6,7 +6,8 @@ AM_CPPFLAGS = -Wall -I${top_srcdir}/include -I${top_builddir}/include -D_GNU_SO
AM_LDFLAGS = -L${top_builddir}/lib -L${top_builddir}/src/lib -lnl-cli
sbin_PROGRAMS = \
- nl-qdisc-add
+ nl-qdisc-add \
+ nl-classid-lookup
noinst_PROGRAMS = \
genl-ctrl-list \
@@ -104,3 +105,6 @@ nl_util_addr_LDADD = -lnl-route
nl_pktloc_lookup_SOURCES = nl-pktloc-lookup.c
nl_pktloc_lookup_LDADD = -lnl-route
+
+nl_classid_lookup_SOURCES = nl-classid-lookup.c
+nl_classid_lookup_LDADD = -lnl-route