summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorJoe Damato <ice799@gmail.com>2013-07-04 01:40:58 (GMT)
committerJoe Damato <ice799@gmail.com>2013-07-19 09:06:21 (GMT)
commit81d2b1d509d91fe894e4aec0a6a76b0bf75514cd (patch)
tree9bf88cb826292b75e17ec86e975e2b644774e4d5 /src/Makefile.am
parent89b00119f213dd7234321324b3ff12ba3e259a93 (diff)
downloadlibnl-81d2b1d509d91fe894e4aec0a6a76b0bf75514cd.zip
libnl-81d2b1d509d91fe894e4aec0a6a76b0bf75514cd.tar.gz
libnl-81d2b1d509d91fe894e4aec0a6a76b0bf75514cd.tar.bz2
Add support for inet diag Netlink protocol.
- Inet diag allows users to gather low-level socket information. - This library provides a higher-level API for creating inetdiag requests (via idiagnl_connect and idiagnl_send_simple) and parsing the replies (via idiagnl_msg_parse). A cache is also provided (via idiagnl_msg_alloc_cache). - Request and message objects provide APIs for accessing and setting the various properties of each. - This library also allows the user to parse the inetdiag response attributes which contain information about traffic class, TOS, congestion, socket memory info, and more depending on the kernel version used. - Includes doxygen documentation.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index c318dcc..6541f6d 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -9,7 +9,8 @@ LDADD = \
${top_builddir}/lib/libnl-3.la \
${top_builddir}/lib/libnl-nf-3.la \
${top_builddir}/lib/libnl-genl-3.la \
- ${top_builddir}/lib/libnl-route-3.la
+ ${top_builddir}/lib/libnl-route-3.la \
+ ${top_builddir}/lib/libnl-idiag-3.la
sbin_PROGRAMS = \
genl-ctrl-list \