summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorRich Fought <rmf.aero@gmail.com>2014-02-27 00:02:13 (GMT)
committerThomas Haller <thaller@redhat.com>2014-04-14 17:20:53 (GMT)
commit8ff199947ffa4f7d4f6b0b878fde68d8ffcf7f0f (patch)
tree620d165c676873f08b600759cb64be3623e662e1 /src/Makefile.am
parentcb319e22f5680b49fad62dc7f0eb35b7d737cb3b (diff)
downloadlibnl-8ff199947ffa4f7d4f6b0b878fde68d8ffcf7f0f.zip
libnl-8ff199947ffa4f7d4f6b0b878fde68d8ffcf7f0f.tar.gz
libnl-8ff199947ffa4f7d4f6b0b878fde68d8ffcf7f0f.tar.bz2
netfilter/ct: expand CT parameters that can be used in add/delete operations
This expands functionality for manipulating conntracks over netlink by adding other attributes to nfnl_ct_build_message(). Added a command link program to add conntracks. https://github.com/thom311/libnl/pull/55 [thaller@redhat.com: cleaned up whitespace from original patch] Acked-by: Thomas Graf <tgraf@suug.ch> Signed-off-by: Thomas Haller <thaller@redhat.com>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index b2b7fc7..f8ac4ca 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -23,7 +23,7 @@ sbin_PROGRAMS = \
nl-link-list
noinst_PROGRAMS = \
- nf-ct-list nf-log nf-queue nf-monitor \
+ nf-ct-list nf-ct-add nf-log nf-queue nf-monitor \
nf-exp-list nf-exp-add nf-exp-delete \
nl-addr-add nl-addr-delete nl-addr-list \
nl-link-set nl-link-stats \
@@ -44,6 +44,7 @@ noinst_PROGRAMS = \
genl_ctrl_list_SOURCES = genl-ctrl-list.c
nf_ct_list_SOURCES = nf-ct-list.c
+nf_ct_add_SOURCES = nf-ct-add.c
nf_log_SOURCES = nf-log.c
nf_queue_SOURCES = nf-queue.c
nf_monitor_SOURCES = nf-monitor.c