summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorJan Engelhardt <jengelh@inai.de>2013-11-26 14:19:45 (GMT)
committerThomas Graf <tgraf@suug.ch>2013-11-27 22:38:50 (GMT)
commitbda0f668b6355e84b1db89d934e8e5062a2ef0bb (patch)
tree304a85abba2398a23bf5e191e1a4f29a12d2a5ba /src/Makefile.am
parentae19ac01545ee2429f2fcbb37b36f8471a5d1498 (diff)
downloadlibnl-bda0f668b6355e84b1db89d934e8e5062a2ef0bb.zip
libnl-bda0f668b6355e84b1db89d934e8e5062a2ef0bb.tar.gz
libnl-bda0f668b6355e84b1db89d934e8e5062a2ef0bb.tar.bz2
build: separate compiler and linker flags
-Wall is a compiler flag, and thus should be in CFLAGS, not CPPFLAGS. Similarly, -l belongs into LDADD/LIBADD because of ordering constraints. Signed-off-by: Jan Engelhardt <jengelh@inai.de> Signed-off-by: Thomas Graf <tgraf@suug.ch>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 87dd871..b2b7fc7 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -2,7 +2,8 @@
SUBDIRS = lib
-AM_CPPFLAGS = -Wall -I${top_srcdir}/include -I${top_builddir}/include -D_GNU_SOURCE -DSYSCONFDIR=\"$(sysconfdir)/libnl\"
+AM_CPPFLAGS = -I${top_srcdir}/include -I${top_builddir}/include -D_GNU_SOURCE -DSYSCONFDIR=\"$(sysconfdir)/libnl\"
+AM_CFLAGS = -Wall
LDADD = \
${top_builddir}/src/lib/libnl-cli-3.la \