summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorJoe Damato <ice799@gmail.com>2013-07-25 23:36:16 (GMT)
committerJoe Damato <ice799@gmail.com>2013-07-25 23:36:16 (GMT)
commitc97c8c2bfdb097ea553e302cc8dbadff2f2b9294 (patch)
treed5a6f1c2e3b6220ef95ef84edb6090fa423e6f50 /src/Makefile.am
parentb3fb89f445108677d405c62865b25aeea209d10a (diff)
downloadlibnl-c97c8c2bfdb097ea553e302cc8dbadff2f2b9294.zip
libnl-c97c8c2bfdb097ea553e302cc8dbadff2f2b9294.tar.gz
libnl-c97c8c2bfdb097ea553e302cc8dbadff2f2b9294.tar.bz2
Add idiag-socket-details
This small program lists all sockets on the system seen by netlink and serves as a simple example showing how to alloc an idiag msg cache and dump the objects in it.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 6541f6d..87dd871 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -37,7 +37,8 @@ noinst_PROGRAMS = \
nl-list-caches nl-list-sockets \
nl-util-addr \
nl-link-enslave \
- nl-link-release
+ nl-link-release \
+ idiag-socket-details
genl_ctrl_list_SOURCES = genl-ctrl-list.c
@@ -99,3 +100,5 @@ nl_util_addr_SOURCES = nl-util-addr.c
nl_pktloc_lookup_SOURCES = nl-pktloc-lookup.c
nl_classid_lookup_SOURCES = nl-classid-lookup.c
+
+idiag_socket_details_SOURCES = idiag-socket-details.c