summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorThomas Haller <thaller@redhat.com>2015-03-18 14:20:28 (GMT)
committerThomas Haller <thaller@redhat.com>2015-03-18 14:36:02 (GMT)
commitff19c781d3b655aba3dcf07a68537c7bae2468b5 (patch)
tree6683b1038cdad76c3329fdc59cf337422216736c /src/Makefile.am
parent0c97b088f1df5b1d56a5ffa75fe736368f1f2586 (diff)
downloadlibnl-ff19c781d3b655aba3dcf07a68537c7bae2468b5.zip
libnl-ff19c781d3b655aba3dcf07a68537c7bae2468b5.tar.gz
libnl-ff19c781d3b655aba3dcf07a68537c7bae2468b5.tar.bz2
build: extend configure option --enable-cli and install all cli programs
Previously, some cli programs were installed to sbin/ and most were not installed at all. Now, by default install all of them to bin/ directory. But extend the configure option to allow specifying 'no-inst', 'bin', or 'sbin'. Acked-by: Thomas Graf <tgraf@suug.ch> Signed-off-by: Thomas Haller <thaller@redhat.com>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am38
1 files changed, 23 insertions, 15 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index aee1c48..a77b328 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -19,22 +19,8 @@ LDADD = \
${top_builddir}/lib/libnl-route-3.la \
${top_builddir}/lib/libnl-idiag-3.la
-sbin_PROGRAMS = \
+cli_programs = \
genl-ctrl-list \
- nl-class-add \
- nl-class-delete \
- nl-classid-lookup \
- nl-class-list \
- nl-cls-add \
- nl-cls-delete \
- nl-cls-list \
- nl-link-list \
- nl-pktloc-lookup \
- nl-qdisc-add \
- nl-qdisc-delete \
- nl-qdisc-list
-
-noinst_PROGRAMS = \
idiag-socket-details \
nf-ct-add \
nf-ct-list \
@@ -47,9 +33,17 @@ noinst_PROGRAMS = \
nl-addr-add \
nl-addr-delete \
nl-addr-list \
+ nl-class-add \
+ nl-class-delete \
+ nl-classid-lookup \
+ nl-class-list \
+ nl-cls-add \
+ nl-cls-delete \
+ nl-cls-list \
nl-fib-lookup \
nl-link-enslave \
nl-link-ifindex2name \
+ nl-link-list \
nl-link-name2ifindex \
nl-link-release \
nl-link-set \
@@ -61,6 +55,10 @@ noinst_PROGRAMS = \
nl-neigh-delete \
nl-neigh-list \
nl-neightbl-list \
+ nl-pktloc-lookup \
+ nl-qdisc-add \
+ nl-qdisc-delete \
+ nl-qdisc-list \
nl-route-add \
nl-route-delete \
nl-route-get \
@@ -69,6 +67,16 @@ noinst_PROGRAMS = \
nl-tctree-list \
nl-util-addr
+if ENABLE_CLI_INSTALL_BIN
+bin_PROGRAMS = $(cli_programs)
+else
+if ENABLE_CLI_INSTALL_SBIN
+sbin_PROGRAMS = $(cli_programs)
+else
+noinst_PROGRAMS = $(cli_programs)
+endif
+endif
+
genl_ctrl_list_SOURCES = genl-ctrl-list.c
nf_ct_list_SOURCES = nf-ct-list.c