summaryrefslogtreecommitdiffstats
path: root/src/lib/Makefile.am
diff options
context:
space:
mode:
authorAndreas Bießmann <biessmann@corscience.de>2010-08-05 13:19:02 (GMT)
committerThomas Graf <tgraf@suug.ch>2010-10-13 12:36:09 (GMT)
commitcb05bbb0e2d38f41569754e1505c22929537c17e (patch)
treec17f463b978fe9e29a606610cf7767ba3f330468 /src/lib/Makefile.am
parent706ac94ed523be847f09d04544d379d35263a930 (diff)
downloadlibnl-cb05bbb0e2d38f41569754e1505c22929537c17e.zip
libnl-cb05bbb0e2d38f41569754e1505c22929537c17e.tar.gz
libnl-cb05bbb0e2d38f41569754e1505c22929537c17e.tar.bz2
automake: add ${top_builddir}/include to AM_CFLAGS
This patch enables out-of-source builds like this $ cd builddir && src_dir/configure && make Before this patch there was an error about missing netlink/version.h which is built by automake in top_builddir rather than top_srcdir which is already in include search path. Signed-off-by: Andreas Bießmann <biessmann@corscience.de>
Diffstat (limited to 'src/lib/Makefile.am')
-rw-r--r--src/lib/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/lib/Makefile.am b/src/lib/Makefile.am
index dd4f6cf..80c217c 100644
--- a/src/lib/Makefile.am
+++ b/src/lib/Makefile.am
@@ -1,6 +1,6 @@
# -*- Makefile -*-
-AM_CPPFLAGS = -Wall -I${top_srcdir}/include -D_GNU_SOURCE -DPKGLIBDIR=\"$(pkglibdir)\" -DSYSCONFDIR=\"$(sysconfdir)\" -rdynamic
+AM_CPPFLAGS = -Wall -I${top_srcdir}/include -I${top_builddir}/include -D_GNU_SOURCE -DPKGLIBDIR=\"$(pkglibdir)\" -DSYSCONFDIR=\"$(sysconfdir)\" -rdynamic
AM_LDFLAGS = -L${top_builddir}/lib -ldl
#nobase_pkglib_LTLIBRARIES = cls/basic.la cls/ematch/cmp.la