summaryrefslogtreecommitdiffstats
path: root/build/meson/meson.build
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz@archlinux.org>2023-01-16 02:51:12 (GMT)
committerEli Schwartz <eschwartz@archlinux.org>2023-01-30 17:55:03 (GMT)
commit7ab223b7fa2f5b28cfaa4c800db78ad82287be40 (patch)
tree22999d2208c0a4cbedb06a1e688433f46cb75a12 /build/meson/meson.build
parent1f3adea1c68ea61f41903d959b4f98f45aa527a7 (diff)
downloadlz4-7ab223b7fa2f5b28cfaa4c800db78ad82287be40.zip
lz4-7ab223b7fa2f5b28cfaa4c800db78ad82287be40.tar.gz
lz4-7ab223b7fa2f5b28cfaa4c800db78ad82287be40.tar.bz2
build: move meson files from contrib, to go alongside other build systems
Diffstat (limited to 'build/meson/meson.build')
-rw-r--r--build/meson/meson.build31
1 files changed, 31 insertions, 0 deletions
diff --git a/build/meson/meson.build b/build/meson/meson.build
new file mode 100644
index 0000000..fc6408a
--- /dev/null
+++ b/build/meson/meson.build
@@ -0,0 +1,31 @@
+# #############################################################################
+# Copyright (c) 2018-present lzutao <taolzu(at)gmail.com>
+# All rights reserved.
+#
+# This source code is licensed under both the BSD-style license (found in the
+# LICENSE file in the root directory of this source tree) and the GPLv2 (found
+# in the COPYING file in the root directory of this source tree).
+# #############################################################################
+
+# This is a dummy meson file.
+# The intention is that it can be easily moved to the root of the project
+# (together with meson_options.txt) and packaged for wrapdb.
+
+project(
+ 'lz4',
+ 'c',
+ license: 'BSD-2-Clause-Patent AND GPL-2.0-or-later',
+ default_options: [
+ 'c_std=c99',
+ 'buildtype=release',
+ 'warning_level=3'
+ ],
+ version: run_command(
+ find_program('GetLz4LibraryVersion.py'),
+ '../../lib/lz4.h',
+ check: true
+ ).stdout().strip(),
+ meson_version: '>=0.58.0'
+)
+
+subdir('meson')