summaryrefslogtreecommitdiffstats
path: root/build/meson/meson/examples/meson.build
diff options
context:
space:
mode:
authorYann Collet <Cyan4973@users.noreply.github.com>2023-02-07 22:59:06 (GMT)
committerGitHub <noreply@github.com>2023-02-07 22:59:06 (GMT)
commit185cf420206cf68a2a5cee8cdaf11145db7cd971 (patch)
tree22999d2208c0a4cbedb06a1e688433f46cb75a12 /build/meson/meson/examples/meson.build
parent1f3adea1c68ea61f41903d959b4f98f45aa527a7 (diff)
parent7ab223b7fa2f5b28cfaa4c800db78ad82287be40 (diff)
downloadlz4-185cf420206cf68a2a5cee8cdaf11145db7cd971.zip
lz4-185cf420206cf68a2a5cee8cdaf11145db7cd971.tar.gz
lz4-185cf420206cf68a2a5cee8cdaf11145db7cd971.tar.bz2
Merge pull request #1207 from eli-schwartz/meson
build: move meson files from contrib, to go alongside other build systems
Diffstat (limited to 'build/meson/meson/examples/meson.build')
-rw-r--r--build/meson/meson/examples/meson.build32
1 files changed, 32 insertions, 0 deletions
diff --git a/build/meson/meson/examples/meson.build b/build/meson/meson/examples/meson.build
new file mode 100644
index 0000000..65f54ca
--- /dev/null
+++ b/build/meson/meson/examples/meson.build
@@ -0,0 +1,32 @@
+# #############################################################################
+# Copyright (c) 2018-present lzutao <taolzu(at)gmail.com>
+# Copyright (c) 2022-present Tristan Partin <tristan(at)partin.io>
+# All rights reserved.
+#
+# This source code is licensed under both the BSD-style license (found in the
+# LICENSE file in the root directory of this source tree) and the GPLv2 (found
+# in the COPYING file in the root directory of this source tree).
+# #############################################################################
+
+lz4_source_root = '../../../..'
+
+examples = {
+ 'printVersion': 'printVersion.c',
+ 'doubleBuffer': 'blockStreaming_doubleBuffer.c',
+ 'dictionaryRandomAccess': 'dictionaryRandomAccess.c',
+ 'ringBuffer': 'blockStreaming_ringBuffer.c',
+ 'ringBufferHC': 'HCStreaming_ringBuffer.c',
+ 'lineCompress': 'blockStreaming_lineByLine.c',
+ 'frameCompress': 'frameCompress.c',
+ 'compressFunctions': 'compress_functions.c',
+ 'simpleBuffer': 'simple_buffer.c',
+}
+
+foreach e, src : examples
+ executable(
+ e,
+ lz4_source_root / 'examples' / src,
+ dependencies: [liblz4_internal_dep],
+ install: false
+ )
+endforeach