summaryrefslogtreecommitdiffstats
path: root/contrib/meson/meson/lib/meson.build
diff options
context:
space:
mode:
authorYann Collet <Cyan4973@users.noreply.github.com>2022-12-05 03:57:14 (GMT)
committerGitHub <noreply@github.com>2022-12-05 03:57:14 (GMT)
commit299daf03acd9b8084ca3fc53403e1fd4c3cbeacd (patch)
tree46abf68545b320bc539e428dd80f5328c827a922 /contrib/meson/meson/lib/meson.build
parente7e7b7ef9e934f666027f061d70a83eef17a9703 (diff)
parent2fc9a85bf8d4f3a67f23dd8cee517d79db39f328 (diff)
downloadlz4-299daf03acd9b8084ca3fc53403e1fd4c3cbeacd.zip
lz4-299daf03acd9b8084ca3fc53403e1fd4c3cbeacd.tar.gz
lz4-299daf03acd9b8084ca3fc53403e1fd4c3cbeacd.tar.bz2
Merge pull request #1184 from tristan957/meson
Meson updates
Diffstat (limited to 'contrib/meson/meson/lib/meson.build')
-rw-r--r--contrib/meson/meson/lib/meson.build9
1 files changed, 5 insertions, 4 deletions
diff --git a/contrib/meson/meson/lib/meson.build b/contrib/meson/meson/lib/meson.build
index f37eec2..009dfcf 100644
--- a/contrib/meson/meson/lib/meson.build
+++ b/contrib/meson/meson/lib/meson.build
@@ -42,6 +42,8 @@ liblz4_dep = declare_dependency(
include_directories: include_directories(lz4_source_root / 'lib')
)
+meson.override_dependency('liblz4', liblz4_dep)
+
if get_option('tests') or get_option('programs') or get_option('examples') or get_option('ossfuzz')
liblz4_internal = static_library(
'lz4-internal',
@@ -73,8 +75,7 @@ install_headers(
if get_option('default_library') != 'shared'
install_headers(lz4_source_root / 'lib/lz4frame_static.h')
-endif
-
-if get_option('unstable')
- install_headers(lz4_source_root / 'lib/lz4file.h')
+ if get_option('unstable')
+ install_headers(lz4_source_root / 'lib/lz4file.h')
+ endif
endif