summaryrefslogtreecommitdiffstats
path: root/contrib/meson/meson/tests/meson.build
diff options
context:
space:
mode:
authorYann Collet <Cyan4973@users.noreply.github.com>2022-12-05 03:57:14 (GMT)
committerGitHub <noreply@github.com>2022-12-05 03:57:14 (GMT)
commit299daf03acd9b8084ca3fc53403e1fd4c3cbeacd (patch)
tree46abf68545b320bc539e428dd80f5328c827a922 /contrib/meson/meson/tests/meson.build
parente7e7b7ef9e934f666027f061d70a83eef17a9703 (diff)
parent2fc9a85bf8d4f3a67f23dd8cee517d79db39f328 (diff)
downloadlz4-299daf03acd9b8084ca3fc53403e1fd4c3cbeacd.zip
lz4-299daf03acd9b8084ca3fc53403e1fd4c3cbeacd.tar.gz
lz4-299daf03acd9b8084ca3fc53403e1fd4c3cbeacd.tar.bz2
Merge pull request #1184 from tristan957/meson
Meson updates
Diffstat (limited to 'contrib/meson/meson/tests/meson.build')
-rw-r--r--contrib/meson/meson/tests/meson.build5
1 files changed, 3 insertions, 2 deletions
diff --git a/contrib/meson/meson/tests/meson.build b/contrib/meson/meson/tests/meson.build
index 71db2e6..df47b83 100644
--- a/contrib/meson/meson/tests/meson.build
+++ b/contrib/meson/meson/tests/meson.build
@@ -45,8 +45,9 @@ test_exes = {
'sources': files(lz4_source_root / 'tests/freestanding.c'),
'c_args': ['-ffreestanding', '-Wno-unused-parameter', '-Wno-declaration-after-statement'],
'link_args': ['-nostdlib'],
- 'build': cc.get_id() in ['gcc', 'clang'],
- 'override_options': ['optimization=1']
+ 'build': cc.get_id() in ['gcc', 'clang'] and
+ host_machine.system() == 'linux' and host_machine.cpu_family() == 'x86_64',
+ 'override_options': ['optimization=1'],
},
'fullbench': {
'sources': files(lz4_source_root / 'tests/fullbench.c'),