summaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorEvgeniy Polyakov <zbr@ioremap.net>2015-08-15 18:32:42 (GMT)
committerEvgeniy Polyakov <zbr@ioremap.net>2015-08-15 18:32:42 (GMT)
commit33fa0bfb74c0a3c3940fca6392807f907010bb30 (patch)
treecf49d2724d5c6471f11fe632c831e865ac9b9b41 /debian
parentb4b739c4bf10dab0dde9e5c92290f1f8d4ec7728 (diff)
downloadlz4-33fa0bfb74c0a3c3940fca6392807f907010bb30.zip
lz4-33fa0bfb74c0a3c3940fca6392807f907010bb30.tar.gz
lz4-33fa0bfb74c0a3c3940fca6392807f907010bb30.tar.bz2
Added debianization
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog8
-rw-r--r--debian/compat1
-rw-r--r--debian/control16
-rw-r--r--debian/copyright9
-rw-r--r--debian/dirs2
-rw-r--r--debian/docs0
-rw-r--r--debian/lz4-dev.install2
-rw-r--r--debian/lz4.install2
-rwxr-xr-xdebian/rules26
9 files changed, 66 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..430c1c7
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,8 @@
+lz4 (0.131) unstable; urgency=low
+
+ * New : Dos/DJGPP target, thanks to Louis Santillan (#114)
+ * Added : Example using lz4frame library, by Zbigniew Jędrzejewski-Szmek (#118)
+ * Changed: xxhash symbols are modified (namespace emulation) within liblz4
+
+ -- Yann Collet <Cyan4973@github.com> Sun, 28 Jun 2015 01:00:00 +0000
+
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..7f8f011
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+7
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..f36e476
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,16 @@
+Source: lz4
+Section: devel
+Priority: optional
+Maintainer: Evgeniy Polyakov <zbr@ioremap.net>
+Build-Depends:
+ cmake (>= 2.6),
+ debhelper (>= 7.0.50~)
+Standards-Version: 3.8.0
+Homepage: https://code.google.com/p/lz4/
+Vcs-Git: git://github.com/Cyan4973/lz4.git
+Vcs-Browser: https://github.com/Cyan4973/lz4
+
+Package: lz4
+Architecture: any
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: Extremely Fast Compression algorithm http://www.lz4.org
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..8b41def
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,9 @@
+Format: http://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
+Upstream-Name: lz4
+Upstream-Contact: Yann Collet <Cyan4973@github.com>
+Source: https://github.com/Cyan4973/lz4
+
+Files: *
+Copyright: (C) 2011+ Yann Collet
+License: GPL-2+
+ The full text of license: https://github.com/Cyan4973/lz4/blob/master/lib/LICENSE
diff --git a/debian/dirs b/debian/dirs
new file mode 100644
index 0000000..ca882bb
--- /dev/null
+++ b/debian/dirs
@@ -0,0 +1,2 @@
+usr/bin
+usr/sbin
diff --git a/debian/docs b/debian/docs
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/debian/docs
diff --git a/debian/lz4-dev.install b/debian/lz4-dev.install
new file mode 100644
index 0000000..85f6809
--- /dev/null
+++ b/debian/lz4-dev.install
@@ -0,0 +1,2 @@
+usr/include/lz4*
+usr/lib/*.so
diff --git a/debian/lz4.install b/debian/lz4.install
new file mode 100644
index 0000000..0bfc1fd
--- /dev/null
+++ b/debian/lz4.install
@@ -0,0 +1,2 @@
+usr/lib/*.so.*
+usr/bin/*
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..06eb09b
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,26 @@
+#!/usr/bin/make -f
+
+%:
+ dh $@ --buildsystem=cmake
+
+override_dh_auto_configure:
+ DESTDIR="$(CURDIR)/debian/lz4" dh_auto_configure \
+ --buildsystem=cmake -- \
+ -DCMAKE_INSTALL_PREFIX="/usr" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ ../cmake_unofficial
+
+override_dh_auto_install:
+ dh_auto_install \
+ --destdir="$(CURDIR)/debian/lz4"
+ --buildsystem=cmake
+
+override_dh_clean:
+ dh_clean
+
+override_dh_makeshlibs:
+ dh_makeshlibs -V "lz4 (>= $(shell dpkg-parsechangelog | sed -n -r -e 's/^Version: ([^.]+\.[^.]+).*/\1/p'))"
+
+override_dh_strip:
+ #dh_strip --dbg-package=lz4-dbg
+