summaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorEvgeniy Polyakov <zbr@ioremap.net>2015-08-15 19:16:39 (GMT)
committerEvgeniy Polyakov <zbr@ioremap.net>2015-08-15 19:16:39 (GMT)
commitb47786b9ed0b98e28bea3f2fe0ecc946f7b59892 (patch)
tree0803afffdb49a94ec3b0f3c8362da806df945c1b /debian
parenta8f33076a37bf37d9b16fd9f982c553afd79028c (diff)
downloadlz4-b47786b9ed0b98e28bea3f2fe0ecc946f7b59892.zip
lz4-b47786b9ed0b98e28bea3f2fe0ecc946f7b59892.tar.gz
lz4-b47786b9ed0b98e28bea3f2fe0ecc946f7b59892.tar.bz2
debian: updated debianization to cdbs
Diffstat (limited to 'debian')
-rw-r--r--debian/control3
-rwxr-xr-xdebian/rules24
2 files changed, 5 insertions, 22 deletions
diff --git a/debian/control b/debian/control
index f36e476..bbbb75a 100644
--- a/debian/control
+++ b/debian/control
@@ -4,7 +4,8 @@ Priority: optional
Maintainer: Evgeniy Polyakov <zbr@ioremap.net>
Build-Depends:
cmake (>= 2.6),
- debhelper (>= 7.0.50~)
+ debhelper (>= 7.0.50~),
+ cdbs
Standards-Version: 3.8.0
Homepage: https://code.google.com/p/lz4/
Vcs-Git: git://github.com/Cyan4973/lz4.git
diff --git a/debian/rules b/debian/rules
index 06eb09b..748e68d 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,26 +1,8 @@
#!/usr/bin/make -f
-%:
- dh $@ --buildsystem=cmake
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/cmake.mk
-override_dh_auto_configure:
- DESTDIR="$(CURDIR)/debian/lz4" dh_auto_configure \
- --buildsystem=cmake -- \
- -DCMAKE_INSTALL_PREFIX="/usr" \
- -DCMAKE_BUILD_TYPE=RelWithDebInfo \
- ../cmake_unofficial
-override_dh_auto_install:
- dh_auto_install \
- --destdir="$(CURDIR)/debian/lz4"
- --buildsystem=cmake
-
-override_dh_clean:
- dh_clean
-
-override_dh_makeshlibs:
- dh_makeshlibs -V "lz4 (>= $(shell dpkg-parsechangelog | sed -n -r -e 's/^Version: ([^.]+\.[^.]+).*/\1/p'))"
-
-override_dh_strip:
- #dh_strip --dbg-package=lz4-dbg
+DEB_CMAKE_EXTRA_FLAGS := -DCMAKE_BUILD_TYPE=RelWithDebInfo ../cmake_unofficial