summaryrefslogtreecommitdiffstats
path: root/build/meson/meson/contrib/gen_manual/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'build/meson/meson/contrib/gen_manual/meson.build')
-rw-r--r--build/meson/meson/contrib/gen_manual/meson.build42
1 files changed, 42 insertions, 0 deletions
diff --git a/build/meson/meson/contrib/gen_manual/meson.build b/build/meson/meson/contrib/gen_manual/meson.build
new file mode 100644
index 0000000..c4349aa
--- /dev/null
+++ b/build/meson/meson/contrib/gen_manual/meson.build
@@ -0,0 +1,42 @@
+# #############################################################################
+# Copyright (c) 2018-present lzutao <taolzu(at)gmail.com>
+# Copyright (c) 2022-present Tristan Partin <tristan(at)partin.io>
+# All rights reserved.
+#
+# This source code is licensed under both the BSD-style license (found in the
+# LICENSE file in the root directory of this source tree) and the GPLv2 (found
+# in the COPYING file in the root directory of this source tree).
+# #############################################################################
+
+lz4_source_root = '../../../../..'
+
+add_languages('cpp', native: true)
+
+sources = files(
+ lz4_source_root / 'contrib/gen_manual/gen_manual.cpp'
+)
+
+gen_manual = executable(
+ 'gen_manual',
+ sources,
+ native: true,
+ install: false
+)
+
+manual_pages = ['lz4', 'lz4frame']
+
+foreach mp : manual_pages
+ custom_target(
+ '@0@_manual.html'.format(mp),
+ build_by_default: true,
+ input: lz4_source_root / 'lib/@0@.h'.format(mp),
+ output: '@0@_manual.html'.format(mp),
+ command: [
+ gen_manual,
+ meson.project_version(),
+ '@INPUT@',
+ '@OUTPUT@',
+ ],
+ install: false
+ )
+endforeach