summaryrefslogtreecommitdiffstats
path: root/build/meson/meson/examples/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'build/meson/meson/examples/meson.build')
-rw-r--r--build/meson/meson/examples/meson.build32
1 files changed, 32 insertions, 0 deletions
diff --git a/build/meson/meson/examples/meson.build b/build/meson/meson/examples/meson.build
new file mode 100644
index 0000000..65f54ca
--- /dev/null
+++ b/build/meson/meson/examples/meson.build
@@ -0,0 +1,32 @@
+# #############################################################################
+# Copyright (c) 2018-present lzutao <taolzu(at)gmail.com>
+# Copyright (c) 2022-present Tristan Partin <tristan(at)partin.io>
+# All rights reserved.
+#
+# This source code is licensed under both the BSD-style license (found in the
+# LICENSE file in the root directory of this source tree) and the GPLv2 (found
+# in the COPYING file in the root directory of this source tree).
+# #############################################################################
+
+lz4_source_root = '../../../..'
+
+examples = {
+ 'printVersion': 'printVersion.c',
+ 'doubleBuffer': 'blockStreaming_doubleBuffer.c',
+ 'dictionaryRandomAccess': 'dictionaryRandomAccess.c',
+ 'ringBuffer': 'blockStreaming_ringBuffer.c',
+ 'ringBufferHC': 'HCStreaming_ringBuffer.c',
+ 'lineCompress': 'blockStreaming_lineByLine.c',
+ 'frameCompress': 'frameCompress.c',
+ 'compressFunctions': 'compress_functions.c',
+ 'simpleBuffer': 'simple_buffer.c',
+}
+
+foreach e, src : examples
+ executable(
+ e,
+ lz4_source_root / 'examples' / src,
+ dependencies: [liblz4_internal_dep],
+ install: false
+ )
+endforeach