summaryrefslogtreecommitdiffstats
path: root/contrib/meson/meson/tests/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/meson/meson/tests/meson.build')
-rw-r--r--contrib/meson/meson/tests/meson.build5
1 files changed, 3 insertions, 2 deletions
diff --git a/contrib/meson/meson/tests/meson.build b/contrib/meson/meson/tests/meson.build
index 71db2e6..df47b83 100644
--- a/contrib/meson/meson/tests/meson.build
+++ b/contrib/meson/meson/tests/meson.build
@@ -45,8 +45,9 @@ test_exes = {
'sources': files(lz4_source_root / 'tests/freestanding.c'),
'c_args': ['-ffreestanding', '-Wno-unused-parameter', '-Wno-declaration-after-statement'],
'link_args': ['-nostdlib'],
- 'build': cc.get_id() in ['gcc', 'clang'],
- 'override_options': ['optimization=1']
+ 'build': cc.get_id() in ['gcc', 'clang'] and
+ host_machine.system() == 'linux' and host_machine.cpu_family() == 'x86_64',
+ 'override_options': ['optimization=1'],
},
'fullbench': {
'sources': files(lz4_source_root / 'tests/fullbench.c'),