summaryrefslogtreecommitdiffstats
path: root/release.nix
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2013-03-06 15:58:24 (GMT)
committerEelco Dolstra <eelco.dolstra@logicblox.com>2013-03-06 15:58:24 (GMT)
commitc330f99196be944846357c242a7cb0cfaf1d4734 (patch)
treec0ab6092c1ebabbb86d4125559b50aa30faf5ee0 /release.nix
parentc9e3ba482a2b9475c984b6cf5c581de78ed320cc (diff)
downloadpatchelf-c330f99196be944846357c242a7cb0cfaf1d4734.zip
patchelf-c330f99196be944846357c242a7cb0cfaf1d4734.tar.gz
patchelf-c330f99196be944846357c242a7cb0cfaf1d4734.tar.bz2
Don't use the "version suffix" stuff in releaseTools.sourceTarball
It's confusing.
Diffstat (limited to 'release.nix')
-rw-r--r--release.nix8
1 files changed, 4 insertions, 4 deletions
diff --git a/release.nix b/release.nix
index dc56eab..f871e99 100644
--- a/release.nix
+++ b/release.nix
@@ -11,12 +11,12 @@ let
tarball =
- pkgs.releaseTools.sourceTarball {
+ pkgs.releaseTools.sourceTarball rec {
name = "patchelf-tarball";
- version = builtins.readFile ./version;
- versionSuffix = if officialRelease then "" else "pre${toString patchelfSrc.revCount}_${patchelfSrc.shortRev}";
+ version = builtins.readFile ./version + (if officialRelease then "" else "pre${toString patchelfSrc.revCount}_${patchelfSrc.shortRev}");
+ versionSuffix = ""; # obsolete
src = patchelfSrc;
- inherit officialRelease;
+ preAutoconf = "echo ${version} > version";
postDist = ''
cp README $out/
echo "doc readme $out/README" >> $out/nix-support/hydra-build-products