summaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2008-05-28 12:29:23 (GMT)
committerEelco Dolstra <e.dolstra@tudelft.nl>2008-05-28 12:29:23 (GMT)
commitdd00c212272e6871983421a480475becc3cdbd40 (patch)
tree10885e50c4b7783d516e271f7ac726cc9a0fb479 /tests/Makefile.am
parent36f96d03dba4a3bf19a3a228786aac5e69ea85d2 (diff)
downloadpatchelf-dd00c212272e6871983421a480475becc3cdbd40.zip
patchelf-dd00c212272e6871983421a480475becc3cdbd40.tar.gz
patchelf-dd00c212272e6871983421a480475becc3cdbd40.tar.bz2
* A test for setting the rpath on a library.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am22
1 files changed, 16 insertions, 6 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 5772fbb..668ec31 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,7 +1,8 @@
-check_PROGRAMS = main simple big-dynstr
+check_PROGRAMS = main main-scoped simple big-dynstr
TESTS = plain-fail.sh plain-run.sh shrink-rpath.sh set-interpreter-short.sh \
- set-interpreter-long.sh set-rpath.sh no-rpath.sh big-dynstr.sh
+ set-interpreter-long.sh set-rpath.sh no-rpath.sh big-dynstr.sh \
+ set-rpath-library.sh
TESTS_ENVIRONMENT = PATCHELF_DEBUG=1
@@ -10,19 +11,28 @@ simple_SOURCES = simple.c
main: main.o libfoo.so
- LD_LIBRARY_PATH=. gcc -o main main.o -L . -lfoo
+ LD_LIBRARY_PATH=. gcc -Wl,--disable-new-dtags -o main main.o -L . -lfoo
+
+main-scoped: main.o libfoo-scoped.so
+ LD_LIBRARY_PATH=. gcc -Wl,--enable-new-dtags -o main-scoped main.o -L . -lfoo-scoped
main.o: main.c
$(CC) -fpic -o main.o -c main.c
libfoo.so: foo.o libbar.so
- $(CC) -shared -o libfoo.so foo.o -L . -lbar
+ NIX_DONT_SET_RPATH=1 $(CC) -Wl,--disable-new-dtags -shared -o libfoo.so foo.o -L . -lbar
+
+libfoo-scoped.so: foo.o libbar-scoped.so
+ NIX_DONT_SET_RPATH=1 $(CC) -Wl,--enable-new-dtags -shared -o libfoo-scoped.so foo.o -L . -lbar-scoped
foo.o: foo.c
$(CC) -fpic -o foo.o -c foo.c
libbar.so: bar.o
- NIX_DONT_SET_RPATH=1 $(CC) -shared -o libbar.so bar.o -L . -Wl,-rpath,`pwd`/no-such-path
+ NIX_DONT_SET_RPATH=1 $(CC) -Wl,--disable-new-dtags -shared -o libbar.so bar.o -L . -Wl,-rpath,`pwd`/no-such-path
+
+libbar-scoped.so: bar.o
+ NIX_DONT_SET_RPATH=1 $(CC) -Wl,--enable-new-dtags -shared -o libbar-scoped.so bar.o
bar.o: bar.c
$(CC) -fpic -o bar.o -c bar.c
@@ -31,7 +41,7 @@ bar.o: bar.c
big_dynstr_SOURCES = big-dynstr.c
big-dynstr: big-dynstr.o libfoo.so
- LD_LIBRARY_PATH=. gcc -o big-dynstr big-dynstr.o -L . -lfoo
+ LD_LIBRARY_PATH=. gcc -Wl,--disable-new-dtags -o big-dynstr big-dynstr.o -L . -lfoo
big-dynstr.c: main.c
cat main.c > big-dynstr.c