summaryrefslogtreecommitdiffstats
path: root/unix/configure.ac
diff options
context:
space:
mode:
authorjan.nijtmans <nijtmans@users.sourceforge.net>2020-01-09 09:28:34 (GMT)
committerjan.nijtmans <nijtmans@users.sourceforge.net>2020-01-09 09:28:34 (GMT)
commit01db149e3c19450429249dab70406917f5e7ff73 (patch)
tree2986418230e49773346674f9afc5a54d949ea804 /unix/configure.ac
parent1afc0833edac82c4216cc08dae31f9da3a9efe26 (diff)
parentf608fa90db6aa15217b86bf87e9d3c9358373195 (diff)
downloadtcl-01db149e3c19450429249dab70406917f5e7ff73.zip
tcl-01db149e3c19450429249dab70406917f5e7ff73.tar.gz
tcl-01db149e3c19450429249dab70406917f5e7ff73.tar.bz2
Merge 8.7
Diffstat (limited to 'unix/configure.ac')
-rw-r--r--unix/configure.ac5
1 files changed, 2 insertions, 3 deletions
diff --git a/unix/configure.ac b/unix/configure.ac
index 434af9d..e9176ad 100644
--- a/unix/configure.ac
+++ b/unix/configure.ac
@@ -180,9 +180,8 @@ if test x"${libtommath_ok}" = x -o x"${libtommath_ok}" != xno; then
AC_CHECK_TYPE([mp_int],[],[libtommath_ok=no],[#include <tommath.h>])],[
libtommath_ok=no])
AS_IF([test $libtommath_ok = yes], [
- AC_SEARCH_LIBS([mp_log_u32],[tommath],[],[
- libtommath_ok=no
- ])])
+ AC_CHECK_LIB([tommath],[mp_log_u32],[MATH_LIBS="$MATH_LIBS -ltommath"],[
+ libtommath_ok=no])])
fi
AS_IF([test $libtommath_ok = yes], [
AC_DEFINE(TCL_WITH_EXTERNAL_TOMMATH, 1, [Tcl with external libtommath])