summaryrefslogtreecommitdiffstats
path: root/unix/configure.ac
diff options
context:
space:
mode:
authorjan.nijtmans <nijtmans@users.sourceforge.net>2021-08-17 16:16:29 (GMT)
committerjan.nijtmans <nijtmans@users.sourceforge.net>2021-08-17 16:16:29 (GMT)
commit5f83d31eceac5d0a48f75293f02725a59168beaf (patch)
tree088ba5712739eee4f6fd1ff277de958420af7021 /unix/configure.ac
parent58502bda0b655dcb2b8e619c1cce4ba99f294aad (diff)
downloadtcl-5f83d31eceac5d0a48f75293f02725a59168beaf.zip
tcl-5f83d31eceac5d0a48f75293f02725a59168beaf.tar.gz
tcl-5f83d31eceac5d0a48f75293f02725a59168beaf.tar.bz2
tip#511 proposed implementation
Diffstat (limited to 'unix/configure.ac')
-rw-r--r--unix/configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/unix/configure.ac b/unix/configure.ac
index 485f13d..b824ede 100644
--- a/unix/configure.ac
+++ b/unix/configure.ac
@@ -318,6 +318,13 @@ if test $tcl_ok = no; then
AC_DEFINE(NO_FD_SET, 1, [Do we have fd_set?])
fi
+AC_CACHE_CHECK([for pselect], tcl_cv_func_pselect, [
+ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <sys/types.h>]], [[void *func = pselect;]])],[tcl_cv_func_pselect=yes],[tcl_cv_func_pselect=no])])
+tcl_ok=$tcl_cv_func_pselect
+if test $tcl_ok = yes; then
+ AC_DEFINE(HAVE_PSELECT, 1, [Should we use pselect()?])
+fi
+
#------------------------------------------------------------------------
# Options for the notifier. Checks for epoll(7) on Linux, and
# kqueue(2) on {DragonFly,Free,Net,Open}BSD