summaryrefslogtreecommitdiffstats
path: root/unix/configure.ac
diff options
context:
space:
mode:
authorjan.nijtmans <nijtmans@users.sourceforge.net>2019-11-05 16:37:52 (GMT)
committerjan.nijtmans <nijtmans@users.sourceforge.net>2019-11-05 16:37:52 (GMT)
commitd010f7c3480b092d396c73d872da43257192a475 (patch)
tree48d45e13e9c79b85aeddc76a32ca49ce48a9e961 /unix/configure.ac
parentc848a8872a27a167d3eba3391874be66feb637c5 (diff)
downloadtcl-d010f7c3480b092d396c73d872da43257192a475.zip
tcl-d010f7c3480b092d396c73d872da43257192a475.tar.gz
tcl-d010f7c3480b092d396c73d872da43257192a475.tar.bz2
More WIP: All makefile builds appear to work fine, makefile.vc build still to be done.
Diffstat (limited to 'unix/configure.ac')
-rw-r--r--unix/configure.ac19
1 files changed, 19 insertions, 0 deletions
diff --git a/unix/configure.ac b/unix/configure.ac
index 6614f5a..c0d08b4 100644
--- a/unix/configure.ac
+++ b/unix/configure.ac
@@ -167,6 +167,25 @@ AS_IF([test $zlib_ok = no], [
])
AC_DEFINE(HAVE_ZLIB, 1, [Is there an installed zlib?])
+#------------------------------------------------------------------------
+# Add stuff for libtommath
+
+libtommath_ok=yes
+AC_CHECK_HEADER([tommath.h],[
+ AC_CHECK_TYPE([mp_int],[],[libtommath_ok=no],[#include <tommath.h>])],[
+ libtommath_ok=no])
+AS_IF([test $libtommath_ok = yes], [
+ AC_SEARCH_LIBS([mp_log_u32],[tommath],[],[
+ libtommath_ok=no
+ ])])
+AS_IF([test $libtommath_ok = yes], [
+ AC_DEFINE(TCL_WITH_EXTERNAL_TOMMATH, 1, [Tcl with external libtommath])
+], [
+ AC_SUBST(TOMMATH_OBJS,[\${TOMMATH_OBJS}])
+ AC_SUBST(TOMMATH_SRCS,[\${TOMMATH_SRCS}])
+ AC_SUBST(TOMMATH_INCLUDE,[-I\${TOMMATH_DIR}])
+])
+
#--------------------------------------------------------------------
# The statements below define a collection of compile flags. This
# macro depends on the value of SHARED_BUILD, and should be called