summaryrefslogtreecommitdiffstats
path: root/unix/configure.ac
diff options
context:
space:
mode:
authorhypnotoad <yoda@etoyoc.com>2017-11-17 04:13:48 (GMT)
committerhypnotoad <yoda@etoyoc.com>2017-11-17 04:13:48 (GMT)
commite84763748b39ba9655d93c056c0bfe614b7cb791 (patch)
tree0e1b90397d5d0210f3784de39ea4f6a4ea24686b /unix/configure.ac
parent8079a467a7b58b840168997dba6b840c81a86be6 (diff)
downloadtcl-e84763748b39ba9655d93c056c0bfe614b7cb791.zip
tcl-e84763748b39ba9655d93c056c0bfe614b7cb791.tar.gz
tcl-e84763748b39ba9655d93c056c0bfe614b7cb791.tar.bz2
First pass on the Msys style windows build. Moving Zipfs features closer together in the autoconf
Diffstat (limited to 'unix/configure.ac')
-rw-r--r--unix/configure.ac41
1 files changed, 19 insertions, 22 deletions
diff --git a/unix/configure.ac b/unix/configure.ac
index b2700cf..35429b5 100644
--- a/unix/configure.ac
+++ b/unix/configure.ac
@@ -155,28 +155,6 @@ if test "$TCLSH_PROG" = ""; then
TCLSH_PROG='./${TCL_EXE}'
fi
-#
-# Check for --enable-zipfs flag
-#
-SC_ENABLE_ZIPFS
-
-#
-# Find a native zip implementation
-#
-SC_PROG_ZIP
-
-#
-# Find a native compiler
-#
-AX_CC_FOR_BUILD
-
-if test "$ZIP_PROG" = ""; then
- ZIP_PROG='./minizip${EXEEXT_FOR_BUILD}'
-fi
-
-
-
-
#------------------------------------------------------------------------
# Add stuff for zlib
#------------------------------------------------------------------------
@@ -818,6 +796,25 @@ AC_MSG_RESULT([$tcl_ok])
# Zipfs support
#--------------------------------------------------------------------
+#
+# Check for --enable-zipfs flag
+#
+SC_ENABLE_ZIPFS
+
+#
+# Find a native zip implementation
+#
+SC_PROG_ZIP
+
+#
+# Find a native compiler
+#
+AX_CC_FOR_BUILD
+
+if test "$ZIP_PROG" = ""; then
+ ZIP_PROG='./minizip${EXEEXT_FOR_BUILD}'
+fi
+
AC_ARG_ENABLE(zipfs,
AC_HELP_STRING([--enable-zipfs],
[build with Zipfs support (default: on)]),