summaryrefslogtreecommitdiffstats
path: root/unix/configure.in
diff options
context:
space:
mode:
authorrmax <rmax>2002-07-29 16:54:40 (GMT)
committerrmax <rmax>2002-07-29 16:54:40 (GMT)
commit37ae57d4d60c1512e5f7751aa2281c93c8093132 (patch)
tree291a71c2236be89384aa78a70cec35de2ef639e2 /unix/configure.in
parent51f3ea4437aa1798abf9e42d125c91110ac674a1 (diff)
downloadtcl-37ae57d4d60c1512e5f7751aa2281c93c8093132.zip
tcl-37ae57d4d60c1512e5f7751aa2281c93c8093132.tar.gz
tcl-37ae57d4d60c1512e5f7751aa2281c93c8093132.tar.bz2
* unix/tcl.m4 (SC_SERIAL_PORT): Fixed detection for cases when
configure's stdin is not a tty. * unix/tclUnixPort.h: * generic/tclIOSock.c: Changed size_t to socklen_t in socket-related function calls. * unix/configure.in: Added test and fallback definition for socklen_t. * unix/configure: generated.
Diffstat (limited to 'unix/configure.in')
-rw-r--r--unix/configure.in18
1 files changed, 17 insertions, 1 deletions
diff --git a/unix/configure.in b/unix/configure.in
index faee73c..2da9e69 100644
--- a/unix/configure.in
+++ b/unix/configure.in
@@ -3,7 +3,7 @@ dnl This file is an input file used by the GNU "autoconf" program to
dnl generate the file "configure", which is run during Tcl installation
dnl to configure the system for the local environment.
#
-# RCS: @(#) $Id: configure.in,v 1.94 2002/07/28 03:15:11 mdejong Exp $
+# RCS: @(#) $Id: configure.in,v 1.95 2002/07/29 16:54:41 rmax Exp $
AC_INIT(../generic/tcl.h)
AC_PREREQ(2.13)
@@ -267,6 +267,22 @@ AC_TYPE_PID_T
AC_TYPE_SIZE_T
AC_TYPE_UID_T
+AC_MSG_CHECKING([for socklen_t])
+AC_CACHE_VAL(ac_cv_type_socklen_t,
+[AC_EGREP_CPP(changequote(<<,>>)dnl
+<<(^|[^a-zA-Z_0-9])socklen_t[^a-zA-Z_0-9]>>dnl
+changequote([,]),[#include <sys/types.h>
+#include <sys/socket.h>
+#if STDC_HEADERS
+#include <stdlib.h>
+#include <stddef.h>
+#endif], ac_cv_type_socklen_t=yes, ac_cv_type_socklen_t=no)
+AC_MSG_RESULT($ac_cv_type_socklen_t)
+if test $ac_cv_type_socklen_t = no; then
+ AC_DEFINE(socklen_t, unsigned)
+fi
+])
+
#--------------------------------------------------------------------
# If a system doesn't have an opendir function (man, that's old!)
# then we have to supply a different version of dirent.h which