summaryrefslogtreecommitdiffstats
path: root/unix/configure.in
diff options
context:
space:
mode:
authordas <das@noemail.net>2007-02-04 02:51:34 (GMT)
committerdas <das@noemail.net>2007-02-04 02:51:34 (GMT)
commit6432350cc12a9477df04b2096a9db7006ffd6e16 (patch)
treef0cde107e30e3c407eed609861ed73f67eb2c5a2 /unix/configure.in
parentb3739a80273ca86cf4d6244f9da7582581ea592c (diff)
downloadtcl-6432350cc12a9477df04b2096a9db7006ffd6e16.zip
tcl-6432350cc12a9477df04b2096a9db7006ffd6e16.tar.gz
tcl-6432350cc12a9477df04b2096a9db7006ffd6e16.tar.bz2
* unix/configure.in: add caching to -pipe check.
* unix/configure: autoconf-2.13 FossilOrigin-Name: c378ec38176408e5a960e2718b3f512e28836049
Diffstat (limited to 'unix/configure.in')
-rw-r--r--unix/configure.in21
1 files changed, 10 insertions, 11 deletions
diff --git a/unix/configure.in b/unix/configure.in
index 6f6eead..149a84d 100644
--- a/unix/configure.in
+++ b/unix/configure.in
@@ -3,7 +3,7 @@ dnl This file is an input file used by the GNU "autoconf" program to
dnl generate the file "configure", which is run during Tcl installation
dnl to configure the system for the local environment.
#
-# RCS: @(#) $Id: configure.in,v 1.106.2.33 2007/01/25 02:06:38 das Exp $
+# RCS: @(#) $Id: configure.in,v 1.106.2.34 2007/02/04 02:51:37 das Exp $
AC_INIT(../generic/tcl.h)
AC_PREREQ(2.13)
@@ -62,16 +62,15 @@ SC_MISSING_POSIX_HEADERS
# It makes compiling go faster. (This is only a performance feature.)
#------------------------------------------------------------------------
-if test -z "$no_pipe"; then
-if test -n "$GCC"; then
- AC_MSG_CHECKING([if the compiler understands -pipe])
- OLDCC="$CC"
- CC="$CC -pipe"
- AC_TRY_COMPILE(,,
- AC_MSG_RESULT([yes]),
- CC="$OLDCC"
- AC_MSG_RESULT([no]))
-fi
+if test -z "$no_pipe" && test -n "$GCC"; then
+ AC_CACHE_CHECK([if the compiler understands -pipe],
+ tcl_cv_cc_pipe, [
+ hold_cflags=$CFLAGS; CFLAGS="$CFLAGS -pipe"
+ AC_TRY_COMPILE(,, tcl_cv_cc_pipe=yes, tcl_cv_cc_pipe=no)
+ CFLAGS=$hold_cflags])
+ if test $tcl_cv_cc_pipe = yes; then
+ CFLAGS="$CFLAGS -pipe"
+ fi
fi
#------------------------------------------------------------------------