summaryrefslogtreecommitdiffstats
path: root/unix/configure.in
diff options
context:
space:
mode:
authorjan.nijtmans <nijtmans@users.sourceforge.net>2020-12-24 12:09:33 (GMT)
committerjan.nijtmans <nijtmans@users.sourceforge.net>2020-12-24 12:09:33 (GMT)
commit67dd971e7082b24d6e1e6d70b5702dcef9cd884c (patch)
tree8e0be1152619714ff1775a6afdb412a0df1b31b3 /unix/configure.in
parent5f6824ef23f3061d7070d75743c6555801aac123 (diff)
downloadtcl-67dd971e7082b24d6e1e6d70b5702dcef9cd884c.zip
tcl-67dd971e7082b24d6e1e6d70b5702dcef9cd884c.tar.gz
tcl-67dd971e7082b24d6e1e6d70b5702dcef9cd884c.tar.bz2
Fix check for broken strstr/strtoul/strtod functions: Modern C compilers don't accept signature mismatches any more.
Diffstat (limited to 'unix/configure.in')
-rw-r--r--unix/configure.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/unix/configure.in b/unix/configure.in
index 27ad5f4..f57d3dc 100644
--- a/unix/configure.in
+++ b/unix/configure.in
@@ -278,7 +278,7 @@ AC_CHECK_FUNC(memmove, , [
#--------------------------------------------------------------------
SC_TCL_CHECK_BROKEN_FUNC(strstr, [
- extern int strstr();
+ extern char *strstr(const char *, const char *);
exit(strstr("\0test", "test") ? 1 : 0);
])
@@ -289,7 +289,7 @@ SC_TCL_CHECK_BROKEN_FUNC(strstr, [
#--------------------------------------------------------------------
SC_TCL_CHECK_BROKEN_FUNC(strtoul, [
- extern int strtoul();
+ extern unsigned long strtoul(const char *, char **, int);
char *term, *string = "0";
exit(strtoul(string,&term,0) != 0 || term != string+1);
])
@@ -300,7 +300,7 @@ SC_TCL_CHECK_BROKEN_FUNC(strtoul, [
#--------------------------------------------------------------------
SC_TCL_CHECK_BROKEN_FUNC(strtod, [
- extern double strtod();
+ extern double strtod(const char *, char **);
char *term, *string = " +69";
exit(strtod(string,&term) != 69 || term != string+4);
])