summaryrefslogtreecommitdiffstats
path: root/unix/configure.in
diff options
context:
space:
mode:
authorhobbs <hobbs>2004-07-16 23:31:17 (GMT)
committerhobbs <hobbs>2004-07-16 23:31:17 (GMT)
commit2235097de407afaaaeeb873f8c73758e17466b08 (patch)
tree132c67d8f1fb73e3f160af8eb6222779efa1a4ac /unix/configure.in
parent34e4fc1cfe224f575700195bda606022f868655e (diff)
downloadtcl-2235097de407afaaaeeb873f8c73758e17466b08.zip
tcl-2235097de407afaaaeeb873f8c73758e17466b08.tar.gz
tcl-2235097de407afaaaeeb873f8c73758e17466b08.tar.bz2
* unix/Makefile.in, unix/tcl.m4: move (C|LD)FLAGS after their
* unix/configure.in, unix/configure: _DEFAULT to allow for env setting to override m4 switches. Move SC_MISSING_POSIX_HEADERS up and consolidate calls to limit redundancy in configure. (CFLAGS_WARNING): Remove -Wconversion (SC_ENABLE_THREADS): Set m4 to force threaded build when built against a threaded Tcl core.
Diffstat (limited to 'unix/configure.in')
-rw-r--r--unix/configure.in28
1 files changed, 13 insertions, 15 deletions
diff --git a/unix/configure.in b/unix/configure.in
index 7d9fc08..6929bb6 100644
--- a/unix/configure.in
+++ b/unix/configure.in
@@ -3,7 +3,7 @@ dnl This file is an input file used by the GNU "autoconf" program to
dnl generate the file "configure", which is run during Tcl installation
dnl to configure the system for the local environment.
#
-# RCS: @(#) $Id: configure.in,v 1.114 2004/06/11 20:25:24 dgp Exp $
+# RCS: @(#) $Id: configure.in,v 1.115 2004/07/16 23:31:37 hobbs Exp $
AC_INIT(../generic/tcl.h)
AC_PREREQ(2.57)
@@ -44,7 +44,17 @@ if test "${CFLAGS+set}" != "set" ; then
fi
AC_PROG_CC
-AC_HAVE_HEADERS(unistd.h limits.h)
+
+#--------------------------------------------------------------------
+# Supply substitutes for missing POSIX header files. Special notes:
+# - stdlib.h doesn't define strtol, strtoul, or
+# strtod insome versions of SunOS
+# - some versions of string.h don't declare procedures such
+# as strstr
+# Do this early, otherwise an autoconf bug throws errors on configure
+#--------------------------------------------------------------------
+
+SC_MISSING_POSIX_HEADERS
#------------------------------------------------------------------------
# Threads support
@@ -82,7 +92,6 @@ fi
SC_TCL_LINK_LIBS
# Add the threads support libraries
-
LIBS="$LIBS$THREADS_LIBS"
SC_ENABLE_SHARED
@@ -133,17 +142,6 @@ AC_CHECK_FUNC(wait3, , [AC_DEFINE(NO_WAIT3)])
AC_CHECK_FUNC(uname, , [AC_DEFINE(NO_UNAME)])
AC_CHECK_FUNC(realpath, , [AC_DEFINE(NO_REALPATH)])
-#--------------------------------------------------------------------
-# Supply substitutes for missing POSIX header files. Special
-# notes:
-# - stdlib.h doesn't define strtol, strtoul, or
-# strtod insome versions of SunOS
-# - some versions of string.h don't declare procedures such
-# as strstr
-#--------------------------------------------------------------------
-
-SC_MISSING_POSIX_HEADERS
-
#---------------------------------------------------------------------------
# Determine which interface to use to talk to the serial port.
# Note that #include lines must begin in leftmost column for
@@ -607,4 +605,4 @@ AC_SUBST(TCL_HAS_LONGLONG)
AC_SUBST(BUILD_DLTEST)
AC_SUBST(TCL_PACKAGE_PATH)
-AC_OUTPUT(Makefile dltest/Makefile tclConfig.sh)
+AC_OUTPUT([Makefile dltest/Makefile tclConfig.sh])