summaryrefslogtreecommitdiffstats
path: root/unix/configure.in
diff options
context:
space:
mode:
authormdejong <mdejong>2003-03-13 10:39:56 (GMT)
committermdejong <mdejong>2003-03-13 10:39:56 (GMT)
commit22544c4ccc233befbc2973f4d503a860faf0df0a (patch)
treee45da1541a5fc8a5316e161607bfefaaa06f724c /unix/configure.in
parentece28abf02c8eb9f9bd99ae1a5d1b268e2ebef69 (diff)
downloadtcl-22544c4ccc233befbc2973f4d503a860faf0df0a.zip
tcl-22544c4ccc233befbc2973f4d503a860faf0df0a.tar.gz
tcl-22544c4ccc233befbc2973f4d503a860faf0df0a.tar.bz2
Require autoconf 2.57 or newer, see TIP 34
for a detailed explanation of why this is good. This will no doubt break the build on some platforms, let the flaming begin. * tools/configure: Regen with autoconf 2.57. * tools/configure.in: Require autoconf 2.57. * unix/configure: Regen with autoconf 2.57. * unix/configure.in: Require autoconf 2.57. Apply AC_LIBOBJ changes from patch 529884. * unix/tcl.m4: Ditto. * win/configure: Regen with autoconf 2.57. * win/configure.in: Require autoconf 2.57. Don't subst LIBOBJS since this happens by default, this avoids an autoconf error.
Diffstat (limited to 'unix/configure.in')
-rw-r--r--unix/configure.in16
1 files changed, 10 insertions, 6 deletions
diff --git a/unix/configure.in b/unix/configure.in
index 77032a3..ce6b5e2 100644
--- a/unix/configure.in
+++ b/unix/configure.in
@@ -3,10 +3,10 @@ dnl This file is an input file used by the GNU "autoconf" program to
dnl generate the file "configure", which is run during Tcl installation
dnl to configure the system for the local environment.
#
-# RCS: @(#) $Id: configure.in,v 1.107 2003/03/04 23:46:19 dgp Exp $
+# RCS: @(#) $Id: configure.in,v 1.108 2003/03/13 10:39:58 mdejong Exp $
AC_INIT(../generic/tcl.h)
-AC_PREREQ(2.13)
+AC_PREREQ(2.57)
TCL_VERSION=8.5
TCL_MAJOR_VERSION=8
@@ -196,7 +196,8 @@ if test $tcl_ok = yes; then
AC_MSG_RESULT(yes)
else
AC_MSG_RESULT([broken, using substitute])
- LIBOBJS="$LIBOBJS strstr.o"
+ AC_LIBOBJ([strstr])
+ USE_COMPAT=1
fi
#--------------------------------------------------------------------
@@ -221,7 +222,8 @@ int main()
}], , tcl_ok=0, tcl_ok=0)
if test "$tcl_ok" = 0; then
test -n "$verbose" && echo " Adding strtoul.o."
- LIBOBJS="$LIBOBJS strtoul.o"
+ AC_LIBOBJ([strtoul])
+ USE_COMPAT=1
fi
#--------------------------------------------------------------------
@@ -245,7 +247,8 @@ int main()
}], , tcl_ok=0, tcl_ok=0)
if test "$tcl_ok" = 0; then
test -n "$verbose" && echo " Adding strtod.o."
- LIBOBJS="$LIBOBJS strtod.o"
+ AC_LIBOBJ([strtod])
+ USE_COMPAT=1
fi
#--------------------------------------------------------------------
@@ -327,7 +330,8 @@ if test "$tcl_ok" = 0; then
AC_CHECK_LIB(inet, strncasecmp, tcl_ok=1, tcl_ok=0)
fi
if test "$tcl_ok" = 0; then
- LIBOBJS="$LIBOBJS strncasecmp.o"
+ AC_LIBOBJ([strncasecmp])
+ USE_COMPAT=1
fi
#--------------------------------------------------------------------