summaryrefslogtreecommitdiffstats
path: root/unix/configure.in
diff options
context:
space:
mode:
authordas <das>2006-09-10 17:04:05 (GMT)
committerdas <das>2006-09-10 17:04:05 (GMT)
commit99f4722bc1aaac286a7546f99abffdea5549c915 (patch)
treec24aaa06cacae7000c359d5823a4ea95e235ac66 /unix/configure.in
parent22f04a9312703adbda93e367fc6af2064f1b14a3 (diff)
downloadtcl-99f4722bc1aaac286a7546f99abffdea5549c915.zip
tcl-99f4722bc1aaac286a7546f99abffdea5549c915.tar.gz
tcl-99f4722bc1aaac286a7546f99abffdea5549c915.tar.bz2
* library/msgcat/msgcat.tcl (msgcat::Init): on Darwin, add fallback of
* tests/msgcat.test: default msgcat locale to * unix/tclUnixInit.c (TclpSetVariables): current CFLocale identifier if available (via private ::tcl::mac::locale global, set at interp init when on Mac OS X 10.3 or later with CoreFoundation). * library/tcltest/tcltest.tcl: add 'line' verbose level: prints source * doc/tcltest.n: file line information of failing tests. * macosx/Tcl.xcodeproj/project.pbxproj: add new tclUnixCompat.c file; revise tests target to use new tcltest 'line' verbose level. * unix/configure.in: add descriptions to new AC_DEFINEs for MT-safe. * unix/tcl.m4: add caching to new SC_TCL_* macros for MT-safe wrappers. * unix/configure: autoconf-2.59 * unix/tclConfig.h.in: autoheader-2.59
Diffstat (limited to 'unix/configure.in')
-rw-r--r--unix/configure.in10
1 files changed, 6 insertions, 4 deletions
diff --git a/unix/configure.in b/unix/configure.in
index 16cf959..1abf209 100644
--- a/unix/configure.in
+++ b/unix/configure.in
@@ -3,7 +3,7 @@ dnl This file is an input file used by the GNU "autoconf" program to
dnl generate the file "configure", which is run during Tcl installation
dnl to configure the system for the local environment.
#
-# RCS: @(#) $Id: configure.in,v 1.146 2006/09/08 20:57:19 vasiljevic Exp $
+# RCS: @(#) $Id: configure.in,v 1.147 2006/09/10 17:04:07 das Exp $
AC_INIT([tcl],[8.5])
AC_PREREQ(2.59)
@@ -175,9 +175,11 @@ if test "${TCL_THREADS}" = 1; then
test "`uname -r | awk -F. '{print [$]1}'`" -gt 5; then
# Starting with Darwin 6 (Mac OSX 10.2), gethostbyX
# are actually MT-safe as they always return pointers
- # from the TSD instead of the static storage.
- AC_DEFINE(HAVE_MTSAFE_GETHOSTBYNAME)
- AC_DEFINE(HAVE_MTSAFE_GETHOSTBYADDR)
+ # from TSD instead of static storage.
+ AC_DEFINE(HAVE_MTSAFE_GETHOSTBYNAME, 1,
+ [Do we have MT-safe gethostbyname() ?])
+ AC_DEFINE(HAVE_MTSAFE_GETHOSTBYADDR, 1,
+ [Do we have MT-safe gethostbyaddr() ?])
else
SC_TCL_GETHOSTBYNAME_R
SC_TCL_GETHOSTBYADDR_R