summaryrefslogtreecommitdiffstats
path: root/unix/configure.in
diff options
context:
space:
mode:
authordas <das>2005-04-26 00:46:01 (GMT)
committerdas <das>2005-04-26 00:46:01 (GMT)
commit24fcde64c436af06b6824359ff50920a2933af27 (patch)
treed2c829948c33b0a374795c6a0e4bc7713a578d48 /unix/configure.in
parente3d20a2783044861949b7a0230410548b1c59982 (diff)
downloadtcl-24fcde64c436af06b6824359ff50920a2933af27.zip
tcl-24fcde64c436af06b6824359ff50920a2933af27.tar.gz
tcl-24fcde64c436af06b6824359ff50920a2933af27.tar.bz2
* compat/string.h: fixed memchr() protoype for __APPLE__ so that we
build on Mac OS X 10.1 again. * generic/tclNotify.c (TclFinalizeNotifier): fixed notifier not being finalized in unthreaded core (was testing for notifier initialization in current thread by checking thread id != 0 but thread id is always 0 in untreaded core). * unix/tclUnixNotfy.c (Tcl_WaitForEvent): sync with HEAD: only declare and use timeout var in unthreaded core. * unix/Makefile.in: added @PLAT_SRCS@ to SRCS and split out NOTIFY_SRCS from UNIX_SRCS for parity with UNIX_OBJS & NOTIFY_OBJS. * unix/configure.in: only run check for broken strstr implementation if AC_REPLACE_FUNCS(strstr) hasn't already determined that strstr is unavailable, otherwise compat/strstr.o will be used twice (resulting in duplicate symbol link errors on Mac OS X 10.1) * unix/tcl.m4 (Darwin): added configure checks for recently added linker flags -single_module and -search_paths_first to allow building with older tools (and on Mac OS X 10.1), use -single_module in SHLIB_LD and not just T{CL,K}_SHLIB_LD_EXTRAS, added unexporting from Tk of symbols from libtclstub to avoid duplicate symbol warnings, added PLAT_SRCS definition for Mac OS X. (SC_MISSING_POSIX_HEADERS): added caching of dirent.h check. (SC_TCL_64BIT_FLAGS): fixed 'checking for off64_t' message output. * unix/configure: autoconf-2.13
Diffstat (limited to 'unix/configure.in')
-rw-r--r--unix/configure.in32
1 files changed, 17 insertions, 15 deletions
diff --git a/unix/configure.in b/unix/configure.in
index 4368615..bb68eb2 100644
--- a/unix/configure.in
+++ b/unix/configure.in
@@ -3,7 +3,7 @@ dnl This file is an input file used by the GNU "autoconf" program to
dnl generate the file "configure", which is run during Tcl installation
dnl to configure the system for the local environment.
#
-# RCS: @(#) $Id: configure.in,v 1.106.2.12 2004/11/25 00:19:33 hobbs Exp $
+# RCS: @(#) $Id: configure.in,v 1.106.2.13 2005/04/26 00:46:03 das Exp $
AC_INIT(../generic/tcl.h)
AC_PREREQ(2.13)
@@ -206,20 +206,22 @@ AC_CHECK_FUNC(memmove, , [AC_DEFINE(NO_MEMMOVE) AC_DEFINE(NO_STRING_H)])
# On some systems strstr is broken: it returns a pointer even
# even if the original string is empty.
#--------------------------------------------------------------------
-
-AC_MSG_CHECKING([proper strstr implementation])
-AC_TRY_RUN([
-extern int strstr();
-int main()
-{
- exit(strstr("\0test", "test") ? 1 : 0);
-}
-], tcl_ok=yes, tcl_ok=no, tcl_ok=no)
-if test $tcl_ok = yes; then
- AC_MSG_RESULT(yes)
-else
- AC_MSG_RESULT([broken, using substitute])
- LIBOBJS="$LIBOBJS strstr.o"
+dnl only run if AC_REPLACE_FUNCS(strstr) hasn't already added strstr.o
+if test "x${ac_cv_func_strstr}" = "xyes"; then
+ AC_MSG_CHECKING([proper strstr implementation])
+ AC_TRY_RUN([
+ extern int strstr();
+ int main()
+ {
+ exit(strstr("\0test", "test") ? 1 : 0);
+ }
+ ], tcl_ok=yes, tcl_ok=no, tcl_ok=no)
+ if test $tcl_ok = yes; then
+ AC_MSG_RESULT(yes)
+ else
+ AC_MSG_RESULT([broken, using substitute])
+ LIBOBJS="$LIBOBJS strstr.o"
+ fi
fi
#--------------------------------------------------------------------