summaryrefslogtreecommitdiffstats
path: root/unix/configure.in
diff options
context:
space:
mode:
authordas <das>2005-05-26 11:19:25 (GMT)
committerdas <das>2005-05-26 11:19:25 (GMT)
commit57ee6386d1f294a81696dd756f6650c50201d918 (patch)
tree09881d76e37d3e83cb0790daebb2de73e921e1e2 /unix/configure.in
parenta4cdc865d7714654fd17a2e9ebb03a26826daecc (diff)
downloadtcl-57ee6386d1f294a81696dd756f6650c50201d918.zip
tcl-57ee6386d1f294a81696dd756f6650c50201d918.tar.gz
tcl-57ee6386d1f294a81696dd756f6650c50201d918.tar.bz2
* macosx/Makefile: moved & corrected EMBEDDED_BUILD check.
* unix/configure.in: corrected framework finalization to softlink stub library to Versions/8.x subdir instead of Versions/Current. * unix/configure: autoconf-2.59
Diffstat (limited to 'unix/configure.in')
-rw-r--r--unix/configure.in8
1 files changed, 4 insertions, 4 deletions
diff --git a/unix/configure.in b/unix/configure.in
index b2d1793..df40574 100644
--- a/unix/configure.in
+++ b/unix/configure.in
@@ -3,7 +3,7 @@ dnl This file is an input file used by the GNU "autoconf" program to
dnl generate the file "configure", which is run during Tcl installation
dnl to configure the system for the local environment.
#
-# RCS: @(#) $Id: configure.in,v 1.106.2.15 2005/05/25 18:49:28 hobbs Exp $
+# RCS: @(#) $Id: configure.in,v 1.106.2.16 2005/05/26 11:19:51 das Exp $
AC_INIT(../generic/tcl.h)
AC_PREREQ(2.13)
@@ -479,8 +479,8 @@ if test "$FRAMEWORK_BUILD" = "1" ; then
tcl_config_files="${tcl_config_files} [Tcl-Info.plist:../macosx/Tcl-Info.plist.in]"
# Construct a fake local framework structure to make linking with
# '-framework Tcl' and running of tcltest work
- AC_OUTPUT_COMMANDS([test "$FRAMEWORK_BUILD" = "1" &&
- n=Tcl && f=$n.framework && v=Versions/$VERSION &&
+ AC_OUTPUT_COMMANDS([test "$FRAMEWORK_BUILD" = "1" && n=Tcl &&
+ f=$n.framework && v=Versions/$VERSION &&
echo "creating $f" && rm -rf $f && mkdir -p $f/$v/Resources &&
ln -s $v/$n $v/Resources $f && ln -s ../../../$n $f/$v &&
ln -s ../../../../$n-Info.plist $f/$v/Resources/Info.plist &&
@@ -503,7 +503,7 @@ if test "$FRAMEWORK_BUILD" = "1" ; then
EXTRA_INSTALL="install-private-headers html-tcl"
EXTRA_BUILD_HTML='@ln -fs contents.htm $(HTML_INSTALL_DIR)/TclTOC.html'
EXTRA_INSTALL_BINARIES='@echo "Installing Info.plist to $(LIB_INSTALL_DIR)/Resources" && mkdir -p "$(LIB_INSTALL_DIR)/Resources" && $(INSTALL_DATA) Tcl-Info.plist "$(LIB_INSTALL_DIR)/Resources/Info.plist"'
- EXTRA_INSTALL_BINARIES="$EXTRA_INSTALL_BINARIES"' && echo "Finalizing Tcl.framework" && rm -f "$(LIB_INSTALL_DIR)/../Current" && ln -s "$(VERSION)" "$(LIB_INSTALL_DIR)/../Current" && for f in "$(LIB_FILE)" "$(STUB_LIB_FILE)" tclConfig.sh Resources Headers PrivateHeaders; do rm -f "$(LIB_INSTALL_DIR)/../../$$f" && ln -s "Versions/Current/$$f" "$(LIB_INSTALL_DIR)/../.."; done'
+ EXTRA_INSTALL_BINARIES="$EXTRA_INSTALL_BINARIES"' && echo "Finalizing Tcl.framework" && rm -f "$(LIB_INSTALL_DIR)/../Current" && ln -s "$(VERSION)" "$(LIB_INSTALL_DIR)/../Current" && for f in "$(LIB_FILE)" tclConfig.sh Resources Headers PrivateHeaders; do rm -f "$(LIB_INSTALL_DIR)/../../$$f" && ln -s "Versions/Current/$$f" "$(LIB_INSTALL_DIR)/../.."; done && f="$(STUB_LIB_FILE)" && rm -f "$(LIB_INSTALL_DIR)/../../$$f" && ln -s "Versions/$(VERSION)/$$f" "$(LIB_INSTALL_DIR)/../.."'
TCL_YEAR="`date +%Y`"
# Don't use AC_DEFINE for the following as the framework version define
# needs to go into the Makefile even when using autoheader, so that we