summaryrefslogtreecommitdiffstats
path: root/unix/configure.in
diff options
context:
space:
mode:
authorhobbs <hobbs>2000-02-10 08:55:14 (GMT)
committerhobbs <hobbs>2000-02-10 08:55:14 (GMT)
commitdd33cec55f8d2792c7b628594c4f0f2d4df7f669 (patch)
tree096ac7fd2b5cc84fae1c4869d6fbbf4e5848c4d2 /unix/configure.in
parent4541ee11ae166c9c275bd5162a5cf79839415b93 (diff)
downloadtcl-dd33cec55f8d2792c7b628594c4f0f2d4df7f669.zip
tcl-dd33cec55f8d2792c7b628594c4f0f2d4df7f669.tar.gz
tcl-dd33cec55f8d2792c7b628594c4f0f2d4df7f669.tar.bz2
* unix/README:
* unix/Makefile.in (dist): removed porting.notes and porting.old from distribution and CVS. The information was very outdated. Now refer to http://dev.scriptics.com/services/support/platforms.html * tests/unixInit.test: fixed japanese LANG encoding test [Bug: 3549] * unix/configure.in: * unix/tcl.m4: correct CFLAG_WARNING setting, fixed gcc config for AIX, added -export-dynamic to LDFLAGS for FreeBSD-3+ [Bug: 2998] * win/tclWinLoad.c (TclpLoadFile): improved error message for load failures, could perhaps be even more intelligent.
Diffstat (limited to 'unix/configure.in')
-rw-r--r--unix/configure.in24
1 files changed, 9 insertions, 15 deletions
diff --git a/unix/configure.in b/unix/configure.in
index ae36606..603de33 100644
--- a/unix/configure.in
+++ b/unix/configure.in
@@ -1,8 +1,9 @@
+#! /bin/bash -norc
dnl This file is an input file used by the GNU "autoconf" program to
dnl generate the file "configure", which is run during Tcl installation
dnl to configure the system for the local environment.
AC_INIT(../generic/tcl.h)
-# RCS: @(#) $Id: configure.in,v 1.55 2000/02/08 10:06:58 hobbs Exp $
+# RCS: @(#) $Id: configure.in,v 1.56 2000/02/10 08:55:27 hobbs Exp $
TCL_VERSION=8.3
TCL_MAJOR_VERSION=8
@@ -36,18 +37,6 @@ AC_HAVE_HEADERS(unistd.h limits.h)
SC_ENABLE_THREADS
-#------------------------------------------------------------------------
-# set the warning flags depending on whether or not we are using gcc
-#------------------------------------------------------------------------
-
-if test "${GCC}" = "yes" ; then
- CFLAGS_WARNING="-Wall -Wconversion"
-else
- CFLAGS_WARNING=""
-fi
-
-AC_SUBST(CFLAGS_WARNING)
-
#------------------------------------------------------------------------------
# If we're using GCC, see if the compiler understands -pipe. If so, use it.
# It makes compiling go faster. (This is only a performance feature.)
@@ -499,8 +488,13 @@ else
# Replace DBGX with TCL_DBGX
eval "TCL_EXP_FILE=\"${TCL_EXP_FILE}\""
- TCL_BUILD_LIB_SPEC="-bI:`pwd`/${TCL_BUILD_EXP_FILE}"
- TCL_LIB_SPEC="-bI:${exec_prefix}/lib/${TCL_EXP_FILE}"
+ if test "$using_gcc" = "yes" ; then
+ TCL_BUILD_LIB_SPEC="-Wl,-bI:`pwd`/${TCL_BUILD_EXP_FILE} -L`pwd`"
+ TCL_LIB_SPEC="-Wl,-bI:${exec_prefix}/lib/${TCL_EXP_FILE} -L`pwd`"
+ else
+ TCL_BUILD_LIB_SPEC="-bI:`pwd`/${TCL_BUILD_EXP_FILE}"
+ TCL_LIB_SPEC="-bI:${exec_prefix}/lib/${TCL_EXP_FILE}"
+ fi
fi
VERSION='${VERSION}'
eval "CFG_TCL_SHARED_LIB_SUFFIX=${TCL_SHARED_LIB_SUFFIX}"