summaryrefslogtreecommitdiffstats
path: root/unix/configure.in
diff options
context:
space:
mode:
authordgp <dgp@users.sourceforge.net>2012-06-21 21:36:48 (GMT)
committerdgp <dgp@users.sourceforge.net>2012-06-21 21:36:48 (GMT)
commit357b7ce73369bce4e0b88aaa87e0b8a2c0eaa853 (patch)
tree3987f89806f1e9cd9163eaf0f87a53b55d9d7a66 /unix/configure.in
parentfeab50ce27318c0af008498d86f1e5fa490a4e80 (diff)
parent607975b5dcc8af44e0fe65ab9ca787ed659e79bd (diff)
downloadtcl-357b7ce73369bce4e0b88aaa87e0b8a2c0eaa853.zip
tcl-357b7ce73369bce4e0b88aaa87e0b8a2c0eaa853.tar.gz
tcl-357b7ce73369bce4e0b88aaa87e0b8a2c0eaa853.tar.bz2
merge trunk
Diffstat (limited to 'unix/configure.in')
-rw-r--r--unix/configure.in9
1 files changed, 3 insertions, 6 deletions
diff --git a/unix/configure.in b/unix/configure.in
index 4fc93dd..726d4a8 100644
--- a/unix/configure.in
+++ b/unix/configure.in
@@ -471,16 +471,13 @@ fi
# The code below deals with several issues related to gettimeofday:
# 1. Some systems don't provide a gettimeofday function at all
# (set NO_GETTOD if this is the case).
-# 2. SGI systems don't use the BSD form of the gettimeofday function,
-# but they have a BSDgettimeofday function that can be used instead.
-# 3. See if gettimeofday is declared in the <sys/time.h> header file.
+# 2. See if gettimeofday is declared in the <sys/time.h> header file.
# if not, set the GETTOD_NOT_DECLARED flag so that tclPort.h can
# declare it.
#--------------------------------------------------------------------
-AC_CHECK_FUNC(BSDgettimeofday,
- [AC_DEFINE(HAVE_BSDGETTIMEOFDAY, 1, [Do we have BSDgettimeofday()?])], [
- AC_CHECK_FUNC(gettimeofday, , [AC_DEFINE(NO_GETTOD, 1, [Do we have gettimeofday()?])])
+AC_CHECK_FUNC(gettimeofday,[],[
+ AC_DEFINE(NO_GETTOD, 1, [Do we have gettimeofday()?])
])
AC_CACHE_CHECK([for gettimeofday declaration], tcl_cv_grep_gettimeofday, [
AC_EGREP_HEADER(gettimeofday, sys/time.h,