summaryrefslogtreecommitdiffstats
path: root/unix/configure.in
diff options
context:
space:
mode:
authordas <das>2006-12-17 03:47:06 (GMT)
committerdas <das>2006-12-17 03:47:06 (GMT)
commite948966663e0c332c86aad5aa167f86f853b9e55 (patch)
tree46ed3f955943f0b626f59adda7a6e0cc020ac4b4 /unix/configure.in
parentaa3f7eb23be4f2cb040b9fd9cf025fc1740a120b (diff)
downloadtcl-e948966663e0c332c86aad5aa167f86f853b9e55.zip
tcl-e948966663e0c332c86aad5aa167f86f853b9e55.tar.gz
tcl-e948966663e0c332c86aad5aa167f86f853b9e55.tar.bz2
* tests/macOSXLoad.test (new file): add testing of .bundle loading and
* tests/load.test: unloading on Darwin (in addition to * tests/unload.test: existing tests of .dylib loading). * macosx/Tcl.xcodeproj/project.pbxproj: add building of dltest binaries so that testsuite run from Xcode can use them; fix testsuite run script. * unix/configure.in: add support for building dltest binaries as * unix/dltest/Makefile.in: .bundle (in addition to .dylib) on Darwin. * unix/Makefile.in: add stub lib dependency to dltest target. * unix/configure: autoconf-2.59
Diffstat (limited to 'unix/configure.in')
-rw-r--r--unix/configure.in11
1 files changed, 10 insertions, 1 deletions
diff --git a/unix/configure.in b/unix/configure.in
index 12955c4..a4de014 100644
--- a/unix/configure.in
+++ b/unix/configure.in
@@ -3,7 +3,7 @@ dnl This file is an input file used by the GNU "autoconf" program to
dnl generate the file "configure", which is run during Tcl installation
dnl to configure the system for the local environment.
#
-# RCS: @(#) $Id: configure.in,v 1.152 2006/11/13 08:23:11 das Exp $
+# RCS: @(#) $Id: configure.in,v 1.153 2006/12/17 03:47:09 das Exp $
AC_INIT([tcl],[8.5])
AC_PREREQ(2.59)
@@ -530,6 +530,12 @@ if test "`uname -s`" = "Darwin" ; then
AC_DEFINE(HAVE_WEAK_IMPORT, 1, [Is weak import available?])
fi
fi
+ # Build .bundle dltest binaries in addition to .dylib
+ DLTEST_LD='${CC} -bundle -Wl,-w ${CFLAGS} ${LDFLAGS}'
+ DLTEST_SUFFIX=".bundle"
+else
+ DLTEST_LD='${SHLIB_LD}'
+ DLTEST_SUFFIX=""
fi
#--------------------------------------------------------------------
@@ -810,6 +816,9 @@ AC_SUBST(EXTRA_INSTALL)
AC_SUBST(EXTRA_INSTALL_BINARIES)
AC_SUBST(EXTRA_BUILD_HTML)
+AC_SUBST(DLTEST_LD)
+AC_SUBST(DLTEST_SUFFIX)
+
dnl Disable the automake-friendly normalization of LIBOBJS
dnl performed by autoconf 2.53 and later. It's not correct for us.
define([_AC_LIBOBJS_NORMALIZE],[])