summaryrefslogtreecommitdiffstats
path: root/unix/configure.in
diff options
context:
space:
mode:
authordas <das>2008-03-13 17:44:15 (GMT)
committerdas <das>2008-03-13 17:44:15 (GMT)
commit082f598b996bdb5c92d2da3c024d1b84b3c2ee7f (patch)
tree42bead27c3e56081942f839cc2fbde21320c5628 /unix/configure.in
parentf3a4d1009e8743428b1f3fab2037a0a42b3c8ace (diff)
downloadtcl-082f598b996bdb5c92d2da3c024d1b84b3c2ee7f.zip
tcl-082f598b996bdb5c92d2da3c024d1b84b3c2ee7f.tar.gz
tcl-082f598b996bdb5c92d2da3c024d1b84b3c2ee7f.tar.bz2
* unix/configure.in: use backspace-quoting instead of double-quoting
* unix/tcl.m4: for lib paths in tclConfig.sh [Bug 1913622]. * unix/configure: autoconf-2.59
Diffstat (limited to 'unix/configure.in')
-rw-r--r--unix/configure.in22
1 files changed, 11 insertions, 11 deletions
diff --git a/unix/configure.in b/unix/configure.in
index 160d7ee..ed4d9c5 100644
--- a/unix/configure.in
+++ b/unix/configure.in
@@ -3,7 +3,7 @@ dnl This file is an input file used by the GNU "autoconf" program to
dnl generate the file "configure", which is run during Tcl installation
dnl to configure the system for the local environment.
#
-# RCS: @(#) $Id: configure.in,v 1.178 2008/03/11 22:28:34 das Exp $
+# RCS: @(#) $Id: configure.in,v 1.179 2008/03/13 17:44:21 das Exp $
AC_INIT([tcl],[8.5])
AC_PREREQ(2.59)
@@ -731,8 +731,8 @@ if test "$FRAMEWORK_BUILD" = "1" ; then
fi
TCL_LIB_FILE="Tcl"
TCL_LIB_FLAG="-framework Tcl"
- TCL_BUILD_LIB_SPEC="-F\"`pwd`\" -framework Tcl"
- TCL_LIB_SPEC="-F\"${libdir}\" -framework Tcl"
+ TCL_BUILD_LIB_SPEC="-F`pwd | sed -e 's/ /\\\\ /g'` -framework Tcl"
+ TCL_LIB_SPEC="-F${libdir} -framework Tcl"
libdir="${libdir}/Tcl.framework/Versions/\${VERSION}"
TCL_LIBRARY="${libdir}/Resources/Scripts"
includedir="${libdir}/Headers"
@@ -757,18 +757,18 @@ else
else
TCL_LIB_FLAG="-ltcl`echo ${TCL_VERSION} | tr -d .`"
fi
- TCL_BUILD_LIB_SPEC="-L\"`pwd`\" ${TCL_LIB_FLAG}"
- TCL_LIB_SPEC="-L\"${libdir}\" ${TCL_LIB_FLAG}"
+ TCL_BUILD_LIB_SPEC="-L`pwd | sed -e 's/ /\\\\ /g'` ${TCL_LIB_FLAG}"
+ TCL_LIB_SPEC="-L${libdir} ${TCL_LIB_FLAG}"
else
TCL_BUILD_EXP_FILE="lib.exp"
eval "TCL_EXP_FILE=libtcl${TCL_EXPORT_FILE_SUFFIX}"
if test "$GCC" = "yes" ; then
- TCL_BUILD_LIB_SPEC="-Wl,-bI:\"`pwd`\"/${TCL_BUILD_EXP_FILE} -L\"`pwd`\""
- TCL_LIB_SPEC="-Wl,-bI:\"${libdir}\"/${TCL_EXP_FILE} -L\"`pwd`\""
+ TCL_BUILD_LIB_SPEC="-Wl,-bI:`pwd | sed -e 's/ /\\\\ /g'`/${TCL_BUILD_EXP_FILE} -L`pwd | sed -e 's/ /\\\\ /g'`"
+ TCL_LIB_SPEC="-Wl,-bI:${libdir}/${TCL_EXP_FILE} -L${libdir}"
else
- TCL_BUILD_LIB_SPEC="-bI:\"`pwd`\"/${TCL_BUILD_EXP_FILE}"
- TCL_LIB_SPEC="-bI:\"${libdir}\"/${TCL_EXP_FILE}"
+ TCL_BUILD_LIB_SPEC="-bI:`pwd | sed -e 's/ /\\\\ /g'`/${TCL_BUILD_EXP_FILE}"
+ TCL_LIB_SPEC="-bI:${libdir}/${TCL_EXP_FILE}"
fi
fi
fi
@@ -814,8 +814,8 @@ else
TCL_STUB_LIB_FLAG="-ltclstub`echo ${TCL_VERSION} | tr -d .`"
fi
-TCL_BUILD_STUB_LIB_SPEC="-L\"`pwd`\" ${TCL_STUB_LIB_FLAG}"
-TCL_STUB_LIB_SPEC="-L\"${TCL_STUB_LIB_DIR}\" ${TCL_STUB_LIB_FLAG}"
+TCL_BUILD_STUB_LIB_SPEC="-L`pwd | sed -e 's/ /\\\\ /g'` ${TCL_STUB_LIB_FLAG}"
+TCL_STUB_LIB_SPEC="-L${TCL_STUB_LIB_DIR} ${TCL_STUB_LIB_FLAG}"
TCL_BUILD_STUB_LIB_PATH="`pwd`/${TCL_STUB_LIB_FILE}"
TCL_STUB_LIB_PATH="${TCL_STUB_LIB_DIR}/${TCL_STUB_LIB_FILE}"