summaryrefslogtreecommitdiffstats
path: root/unix/configure.in
diff options
context:
space:
mode:
authorjenglish <jenglish@flightlab.com>2008-02-26 21:19:51 (GMT)
committerjenglish <jenglish@flightlab.com>2008-02-26 21:19:51 (GMT)
commit2c695fbcd0bcccce2bb7bd362c5088789a96eb5a (patch)
treea882a14a15dfedc2bd7b6d24a57a424d8ffb64bb /unix/configure.in
parent480791e56d8ff26684b9510b81edbf9bc8fe89c2 (diff)
downloadtcl-2c695fbcd0bcccce2bb7bd362c5088789a96eb5a.zip
tcl-2c695fbcd0bcccce2bb7bd362c5088789a96eb5a.tar.gz
tcl-2c695fbcd0bcccce2bb7bd362c5088789a96eb5a.tar.bz2
Define socklen_t as "int" if missing, not "unsigned".
(accept(2) et. al. traditionally took "int *" before POSIX invented socklen_t) Use AC_TRY_COMPILE instead of AC_EGREP_HEADER for socklen_t test. Regenerated configure script.
Diffstat (limited to 'unix/configure.in')
-rw-r--r--unix/configure.in20
1 files changed, 8 insertions, 12 deletions
diff --git a/unix/configure.in b/unix/configure.in
index 6c76fc0..50fb99a 100644
--- a/unix/configure.in
+++ b/unix/configure.in
@@ -3,7 +3,7 @@ dnl This file is an input file used by the GNU "autoconf" program to
dnl generate the file "configure", which is run during Tcl installation
dnl to configure the system for the local environment.
#
-# RCS: @(#) $Id: configure.in,v 1.176 2008/02/13 18:00:40 dgp Exp $
+# RCS: @(#) $Id: configure.in,v 1.177 2008/02/26 21:19:51 jenglish Exp $
AC_INIT([tcl],[8.5])
AC_PREREQ(2.59)
@@ -321,18 +321,14 @@ AC_TYPE_SIZE_T
AC_TYPE_UID_T
AC_CACHE_CHECK([for socklen_t], tcl_cv_type_socklen_t, [
- AC_EGREP_CPP(changequote(<<,>>)dnl
-<<(^|[^a-zA-Z_0-9])socklen_t[^a-zA-Z_0-9]>>dnl
-changequote([,]),[
- #include <sys/types.h>
- #include <sys/socket.h>
- #if STDC_HEADERS
- #include <stdlib.h>
- #include <stddef.h>
- #endif
- ], tcl_cv_type_socklen_t=yes, tcl_cv_type_socklen_t=no)])
+ AC_TRY_COMPILE([
+ #include <sys/types.h>
+ #include <sys/socket.h>
+ ],[
+ socklen_t foo;
+ ],[tcl_cv_type_socklen_t=yes],[tcl_cv_type_socklen_t=no])])
if test $tcl_cv_type_socklen_t = no; then
- AC_DEFINE(socklen_t, unsigned, [What is the type of socklen_t?])
+ AC_DEFINE(socklen_t, int, [Define as int if socklen_t is not available])
fi
AC_CHECK_TYPE([intptr_t], [