summaryrefslogtreecommitdiffstats
path: root/unix/configure.in
diff options
context:
space:
mode:
authormdejong <mdejong>2005-07-26 20:26:27 (GMT)
committermdejong <mdejong>2005-07-26 20:26:27 (GMT)
commit82117336431423ec510476abc4c9d414e174bed5 (patch)
tree09f35638fe1ff6e7be0b31b835662e821792cfb0 /unix/configure.in
parent9d5713e7c5fda9f025636e41099395211bc6612d (diff)
downloadtcl-82117336431423ec510476abc4c9d414e174bed5.zip
tcl-82117336431423ec510476abc4c9d414e174bed5.tar.gz
tcl-82117336431423ec510476abc4c9d414e174bed5.tar.bz2
* unix/configure: Regen.
* unix/configure.in: Check for a $prefix/share directory and add it the the package if found. This will check for Tcl packages in /usr/local/share when Tcl is configured with the default dist install. [patch 1231015]
Diffstat (limited to 'unix/configure.in')
-rw-r--r--unix/configure.in9
1 files changed, 8 insertions, 1 deletions
diff --git a/unix/configure.in b/unix/configure.in
index ad3cc18..e408a9e 100644
--- a/unix/configure.in
+++ b/unix/configure.in
@@ -3,7 +3,7 @@ dnl This file is an input file used by the GNU "autoconf" program to
dnl generate the file "configure", which is run during Tcl installation
dnl to configure the system for the local environment.
#
-# RCS: @(#) $Id: configure.in,v 1.106.2.18 2005/06/18 19:24:25 dgp Exp $
+# RCS: @(#) $Id: configure.in,v 1.106.2.19 2005/07/26 20:26:34 mdejong Exp $
AC_INIT(../generic/tcl.h)
AC_PREREQ(2.13)
@@ -558,6 +558,13 @@ else
TCL_PACKAGE_PATH="${prefix}/lib"
fi
+# If a system share directory like /usr/local/share already exists, then add
+# it to the package search path.
+
+if test -d "${prefix}/share" ; then
+ TCL_PACKAGE_PATH="${TCL_PACKAGE_PATH} ${prefix}/share"
+fi
+
#--------------------------------------------------------------------
# The statements below define various symbols relating to Tcl
# stub support.