summaryrefslogtreecommitdiffstats
path: root/unix/configure.in
diff options
context:
space:
mode:
authordas <das>2008-08-13 23:07:27 (GMT)
committerdas <das>2008-08-13 23:07:27 (GMT)
commit9275a5bc8db6801fe07226b36baa4370158a3bcb (patch)
treeaa4af0b09c34e61f9029959df3223df2bca38ae4 /unix/configure.in
parentb239b96cfda8b81609049fa935a22c8a12c69ce0 (diff)
downloadtcl-9275a5bc8db6801fe07226b36baa4370158a3bcb.zip
tcl-9275a5bc8db6801fe07226b36baa4370158a3bcb.tar.gz
tcl-9275a5bc8db6801fe07226b36baa4370158a3bcb.tar.bz2
* unix/Makefile.in: ensure Makefile shell is /bin/bash for
* unix/configure.in (SunOS): DTrace-enabled build on Solaris. (followup to 2008-06-12) [Bug 2016584]
Diffstat (limited to 'unix/configure.in')
-rw-r--r--unix/configure.in5
1 files changed, 4 insertions, 1 deletions
diff --git a/unix/configure.in b/unix/configure.in
index d3e004c..478428c 100644
--- a/unix/configure.in
+++ b/unix/configure.in
@@ -3,7 +3,7 @@ dnl This file is an input file used by the GNU "autoconf" program to
dnl generate the file "configure", which is run during Tcl installation
dnl to configure the system for the local environment.
#
-# RCS: @(#) $Id: configure.in,v 1.106.2.44 2008/06/12 06:37:04 das Exp $
+# RCS: @(#) $Id: configure.in,v 1.106.2.45 2008/08/13 23:07:27 das Exp $
AC_INIT(../generic/tcl.h)
AC_PREREQ(2.13)
@@ -544,6 +544,7 @@ if test $tcl_ok = yes; then
test -z "$ac_cv_path_DTRACE" && tcl_ok=no
fi
AC_MSG_CHECKING([whether to enable DTrace support])
+MAKEFILE_SHELL='/bin/sh'
if test $tcl_ok = yes; then
AC_DEFINE(USE_DTRACE)
DTRACE_SRC="\${DTRACE_SRC}"
@@ -554,6 +555,7 @@ if test $tcl_ok = yes; then
# Need to create an intermediate object file to ensure tclDTrace.o
# gets included when linking against the static tcl library.
STLIB_LD='stlib_ld () { /usr/ccs/bin/ld -r -o $${1%.a}.o "$${@:2}" && '"${STLIB_LD}"' $${1} $${1%.a}.o ; } && stlib_ld'
+ MAKEFILE_SHELL='/bin/bash'
# Force use of Sun ar and ranlib, the GNU versions choke on
# tclDTrace.o and the combined object file above.
AR='/usr/ccs/bin/ar'
@@ -755,6 +757,7 @@ AC_SUBST(TCL_HAS_LONGLONG)
AC_SUBST(DTRACE_SRC)
AC_SUBST(DTRACE_HDR)
AC_SUBST(DTRACE_OBJ)
+AC_SUBST(MAKEFILE_SHELL)
AC_SUBST(BUILD_DLTEST)
AC_SUBST(TCL_PACKAGE_PATH)