summaryrefslogtreecommitdiffstats
path: root/unix/configure.in
diff options
context:
space:
mode:
authorjan.nijtmans <nijtmans@users.sourceforge.net>2011-03-10 21:32:38 (GMT)
committerjan.nijtmans <nijtmans@users.sourceforge.net>2011-03-10 21:32:38 (GMT)
commitce5b8b9cfc086b57d374c80ce483be55564f0895 (patch)
treeaab3e98644bbfdde7cee9e7d0644843efc3b481b /unix/configure.in
parent2b0f7b4b159055bf1ef1f1a51a31ab0373929824 (diff)
downloadtcl-ce5b8b9cfc086b57d374c80ce483be55564f0895.zip
tcl-ce5b8b9cfc086b57d374c80ce483be55564f0895.tar.gz
tcl-ce5b8b9cfc086b57d374c80ce483be55564f0895.tar.bz2
[Bug 3205320]: stack space detection defeated by inlining
Diffstat (limited to 'unix/configure.in')
-rw-r--r--unix/configure.in8
1 files changed, 5 insertions, 3 deletions
diff --git a/unix/configure.in b/unix/configure.in
index 87731a1..473758d 100644
--- a/unix/configure.in
+++ b/unix/configure.in
@@ -705,11 +705,13 @@ AC_CACHE_CHECK([if the C stack grows upwards in memory], tcl_cv_stack_grows_up,
AC_TRY_RUN([
int StackGrowsUp(int *parent) {
int here;
- return (&here < parent);
+ if (parent)
+ return (&here < parent);
+ else
+ return StackGrowsUp(&here);
}
int main (int argc, char *argv[]) {
- int foo;
- return StackGrowsUp(&foo);
+ return StackGrowsUp(0);
}
], tcl_cv_stack_grows_up=yes, tcl_cv_stack_grows_up=no,
tcl_cv_stack_grows_up=unknown)])