summaryrefslogtreecommitdiffstats
path: root/unix/configure.in
diff options
context:
space:
mode:
authordas <das>2007-04-23 20:38:20 (GMT)
committerdas <das>2007-04-23 20:38:20 (GMT)
commitb967b536f3733422c73415987136c8fb19c6f398 (patch)
tree492bc3dca921756de64802d8e9344cbde53b6727 /unix/configure.in
parent11ca07659da95471c4052ca8a89031838f4ba3ea (diff)
downloadtcl-b967b536f3733422c73415987136c8fb19c6f398.zip
tcl-b967b536f3733422c73415987136c8fb19c6f398.tar.gz
tcl-b967b536f3733422c73415987136c8fb19c6f398.tar.bz2
* unix/configure.in: install license.terms into Tcl.framework.
* unix/configure: autoconf-2.59
Diffstat (limited to 'unix/configure.in')
-rw-r--r--unix/configure.in3
1 files changed, 2 insertions, 1 deletions
diff --git a/unix/configure.in b/unix/configure.in
index 1ea3758..07648a6 100644
--- a/unix/configure.in
+++ b/unix/configure.in
@@ -3,7 +3,7 @@ dnl This file is an input file used by the GNU "autoconf" program to
dnl generate the file "configure", which is run during Tcl installation
dnl to configure the system for the local environment.
#
-# RCS: @(#) $Id: configure.in,v 1.155 2007/02/04 02:51:24 das Exp $
+# RCS: @(#) $Id: configure.in,v 1.156 2007/04/23 20:38:21 das Exp $
AC_INIT([tcl],[8.5])
AC_PREREQ(2.59)
@@ -689,6 +689,7 @@ if test "$FRAMEWORK_BUILD" = "1" ; then
EXTRA_INSTALL="install-private-headers html-tcl"
EXTRA_BUILD_HTML='@ln -fs contents.htm $(HTML_INSTALL_DIR)/TclTOC.html'
EXTRA_INSTALL_BINARIES='@echo "Installing Info.plist to $(LIB_INSTALL_DIR)/Resources" && mkdir -p "$(LIB_INSTALL_DIR)/Resources" && $(INSTALL_DATA) Tcl-Info.plist "$(LIB_INSTALL_DIR)/Resources/Info.plist"'
+ EXTRA_INSTALL_BINARIES="$EXTRA_INSTALL_BINARIES"' && echo "Installing license.terms to $(LIB_INSTALL_DIR)/Resources" && $(INSTALL_DATA) "$(TOP_DIR)/license.terms" "$(LIB_INSTALL_DIR)/Resources"'
EXTRA_INSTALL_BINARIES="$EXTRA_INSTALL_BINARIES"' && echo "Finalizing Tcl.framework" && rm -f "$(LIB_INSTALL_DIR)/../Current" && ln -s "$(VERSION)" "$(LIB_INSTALL_DIR)/../Current" && for f in "$(LIB_FILE)" tclConfig.sh Resources Headers PrivateHeaders; do rm -f "$(LIB_INSTALL_DIR)/../../$$f" && ln -s "Versions/Current/$$f" "$(LIB_INSTALL_DIR)/../.."; done && f="$(STUB_LIB_FILE)" && rm -f "$(LIB_INSTALL_DIR)/../../$$f" && ln -s "Versions/$(VERSION)/$$f" "$(LIB_INSTALL_DIR)/../.."'
TCL_YEAR="`date +%Y`"
# Don't use AC_DEFINE for the following as the framework version define