summaryrefslogtreecommitdiffstats
path: root/unix/configure.in
diff options
context:
space:
mode:
authorjan.nijtmans <nijtmans@users.sourceforge.net>2012-04-24 20:21:16 (GMT)
committerjan.nijtmans <nijtmans@users.sourceforge.net>2012-04-24 20:21:16 (GMT)
commit40cddf0eb5289dc809a95140da0fef1e2d2e2f82 (patch)
treef7587ec802d28b8abaedf99e98dd2ba9084c5e6f /unix/configure.in
parent6f14ff020a548ab6adcb30836c498ab0fe921970 (diff)
parent4f07974ad48f283b3c7bc0aa520b59a8450771cb (diff)
downloadtcl-40cddf0eb5289dc809a95140da0fef1e2d2e2f82.zip
tcl-40cddf0eb5289dc809a95140da0fef1e2d2e2f82.tar.gz
tcl-40cddf0eb5289dc809a95140da0fef1e2d2e2f82.tar.bz2
[Bug 3508771] load tclreg.dll in cygwin tclsh
Implement TclWinGetSockOpt, TclWinGetServByName and TclWinCPUID for Cygwin
Diffstat (limited to 'unix/configure.in')
-rw-r--r--unix/configure.in14
1 files changed, 14 insertions, 0 deletions
diff --git a/unix/configure.in b/unix/configure.in
index fbf9f41..c04c735 100644
--- a/unix/configure.in
+++ b/unix/configure.in
@@ -566,6 +566,20 @@ fi
AC_MSG_RESULT([$tcl_ok])
#--------------------------------------------------------------------
+# The check below checks whether the cpuid instruction is usable.
+#--------------------------------------------------------------------
+
+AC_CACHE_CHECK([whether the cpuid instruction is usable], tcl_cv_cpuid, [
+ AC_TRY_LINK(, [
+ int index,ax,bx,cx,dx;
+ __asm__ __volatile__ ("cpuid":\
+ "=a" (ax), "=b" (bx), "=c" (cx), "=d" (dx) : "a" (index));
+ ], tcl_cv_cpuid=yes, tcl_cv_cpuid=no)])
+if test $tcl_cv_cpuid = yes; then
+ AC_DEFINE(HAVE_CPUID)
+fi
+
+#--------------------------------------------------------------------
# The statements below define a collection of symbols related to
# building libtcl as a shared library instead of a static library.
#--------------------------------------------------------------------