summaryrefslogtreecommitdiffstats
path: root/unix/configure.in
diff options
context:
space:
mode:
authordgp <dgp@users.sourceforge.net>2016-04-19 20:35:49 (GMT)
committerdgp <dgp@users.sourceforge.net>2016-04-19 20:35:49 (GMT)
commit66032e8a327e0498b0d8970307452f66c69be25c (patch)
tree345b92b9d0c1be0f8ff45032a38884929744545e /unix/configure.in
parent0a228666ae8b3189ae92ff7624263de1455c24ff (diff)
downloadtcl-66032e8a327e0498b0d8970307452f66c69be25c.zip
tcl-66032e8a327e0498b0d8970307452f66c69be25c.tar.gz
tcl-66032e8a327e0498b0d8970307452f66c69be25c.tar.bz2
Fork of Tcl used in the "Little" project.
http://www.mcvoy.com/lm/little/index.html
Diffstat (limited to 'unix/configure.in')
-rw-r--r--unix/configure.in31
1 files changed, 31 insertions, 0 deletions
diff --git a/unix/configure.in b/unix/configure.in
index ce68391..a3802e1 100644
--- a/unix/configure.in
+++ b/unix/configure.in
@@ -86,6 +86,7 @@ fi
AC_PROG_CC
AC_C_INLINE
+AC_PROG_BISON
#--------------------------------------------------------------------
# Supply substitutes for missing POSIX header files. Special notes:
# - stdlib.h doesn't define strtol, strtoul, or
@@ -136,6 +137,7 @@ SC_TCL_CFG_ENCODING
#--------------------------------------------------------------------
SC_TCL_LINK_LIBS
+AC_SEARCH_LIBS(inet_aton, resolv)
# Add the threads support libraries
LIBS="$LIBS$THREADS_LIBS"
@@ -307,6 +309,12 @@ fi
SC_TIME_HANDLER
+#------------------------------------------------------------------------------
+# Check if we want to use pcre
+#------------------------------------------------------------------------------
+
+SC_ENABLE_PCRE
+
#--------------------------------------------------------------------
# Some systems (e.g., IRIX 4.0.5) lack some fields in struct stat. But
# we might be able to use fstatfs instead. Some systems (OpenBSD?) also
@@ -399,6 +407,19 @@ if test $tcl_cv_type_socklen_t = no; then
AC_DEFINE(socklen_t, int, [Define as int if socklen_t is not available])
fi
+# check for SHUT_RD and SHUT_WR being enums vs defines
+AC_CACHE_CHECK([for SHUT_RD/SHUT_WR], tcl_cv_type_shutrd, [
+ AC_TRY_COMPILE([
+ #include <sys/socket.h>
+ ],[
+ int foo = SHUT_RD;
+ int bar = SHUT_WR;
+ ],[tcl_cv_type_shutrd=yes],[tcl_cv_type_shutrd=no])])
+if test $tcl_cv_type_shutrd = no; then
+ AC_DEFINE(SHUT_RD, 0, [SHUT_RD not found, define as 0])
+ AC_DEFINE(SHUT_WR, 1, [SHUT_WR not found, define as 1])
+fi
+
AC_CHECK_TYPE([intptr_t], [
AC_DEFINE([HAVE_INTPTR_T], 1, [Do we have the intptr_t type?])], [
AC_CACHE_CHECK([for pointer-size signed integer type], tcl_cv_intptr_t, [
@@ -440,6 +461,8 @@ AC_CHECK_TYPE([uintptr_t], [
AC_CHECK_FUNC(opendir, , [AC_DEFINE(USE_DIRENT2_H, 1, [May we include <dirent2.h>?])])
+AC_STRUCT_DIRENT_D_TYPE
+
#--------------------------------------------------------------------
# The check below checks whether <sys/wait.h> defines the type
# "union wait" correctly. It's needed because of weirdness in
@@ -575,6 +598,14 @@ if test $tcl_cv_isnan = no; then
fi
#--------------------------------------------------------------------
+# Work around apparent fork() problem on netbsd 4.
+#--------------------------------------------------------------------
+
+if test "`uname -s`" = "NetBSD" ; then
+ AC_DEFINE(USE_VFORK, 1, [Should we use vfork() instead of fork()?])
+fi
+
+#--------------------------------------------------------------------
# Darwin specific API checks and defines
#--------------------------------------------------------------------