summaryrefslogtreecommitdiffstats
path: root/unix/configure.in
diff options
context:
space:
mode:
authorjenglish <jenglish@flightlab.com>2013-03-01 23:53:49 (GMT)
committerjenglish <jenglish@flightlab.com>2013-03-01 23:53:49 (GMT)
commit6f42bd76847d33c1e7bbfbf328b7cf591e33d6a1 (patch)
tree3ea698ca5bd081350e1aaa3fcbbadd3392e452b0 /unix/configure.in
parent1e1bbd03fb656021da2e16d78b39336c2537f169 (diff)
downloadtcl-6f42bd76847d33c1e7bbfbf328b7cf591e33d6a1.zip
tcl-6f42bd76847d33c1e7bbfbf328b7cf591e33d6a1.tar.gz
tcl-6f42bd76847d33c1e7bbfbf328b7cf591e33d6a1.tar.bz2
Replace broken SC_SERIAL_PORT macro with plain AC_CHECK_HEADERS tests.
Diffstat (limited to 'unix/configure.in')
-rw-r--r--unix/configure.in13
1 files changed, 9 insertions, 4 deletions
diff --git a/unix/configure.in b/unix/configure.in
index 087bb05..19db579 100644
--- a/unix/configure.in
+++ b/unix/configure.in
@@ -259,12 +259,17 @@ if test "${TCL_THREADS}" = 1; then
fi
#---------------------------------------------------------------------------
-# Determine which interface to use to talk to the serial port.
-# Note that #include lines must begin in leftmost column for
-# some compilers to recognize them as preprocessor directives.
+# Check for serial port interface.
+#
+# termios.h is present on all POSIX systems.
+# sys/ioctl.h is almost always present, though what it contains
+# is system-specific.
+# sys/modem.h is needed on HP-UX.
#---------------------------------------------------------------------------
-SC_SERIAL_PORT
+AC_CHECK_HEADERS(termios.h)
+AC_CHECK_HEADERS(sys/ioctl.h)
+AC_CHECK_HEADERS(sys/modem.h)
#--------------------------------------------------------------------
# Include sys/select.h if it exists and if it supplies things