summaryrefslogtreecommitdiffstats
path: root/unix/configure.in
diff options
context:
space:
mode:
authordgp <dgp@users.sourceforge.net>2012-06-08 13:25:24 (GMT)
committerdgp <dgp@users.sourceforge.net>2012-06-08 13:25:24 (GMT)
commite39d5419c36351fd1e67f48b94934998ddf15785 (patch)
tree423de990eac2d2fba9c642cee683bfcbc706a58a /unix/configure.in
parent1c287f81b4cc32553c3336ad9f095f0e422b7116 (diff)
parent7e302d3ca75cd9eb6998e895cf344665b1d08e5e (diff)
downloadtcl-e39d5419c36351fd1e67f48b94934998ddf15785.zip
tcl-e39d5419c36351fd1e67f48b94934998ddf15785.tar.gz
tcl-e39d5419c36351fd1e67f48b94934998ddf15785.tar.bz2
3530533 Centralize #include <pthread.h> in the tclUnixPort.h header so that
old unix systems that need inclusion in all compilation units are supported. Update autogoo for gettimeofday(). Thanks Joe English.
Diffstat (limited to 'unix/configure.in')
-rw-r--r--unix/configure.in9
1 files changed, 3 insertions, 6 deletions
diff --git a/unix/configure.in b/unix/configure.in
index 4fc93dd..726d4a8 100644
--- a/unix/configure.in
+++ b/unix/configure.in
@@ -471,16 +471,13 @@ fi
# The code below deals with several issues related to gettimeofday:
# 1. Some systems don't provide a gettimeofday function at all
# (set NO_GETTOD if this is the case).
-# 2. SGI systems don't use the BSD form of the gettimeofday function,
-# but they have a BSDgettimeofday function that can be used instead.
-# 3. See if gettimeofday is declared in the <sys/time.h> header file.
+# 2. See if gettimeofday is declared in the <sys/time.h> header file.
# if not, set the GETTOD_NOT_DECLARED flag so that tclPort.h can
# declare it.
#--------------------------------------------------------------------
-AC_CHECK_FUNC(BSDgettimeofday,
- [AC_DEFINE(HAVE_BSDGETTIMEOFDAY, 1, [Do we have BSDgettimeofday()?])], [
- AC_CHECK_FUNC(gettimeofday, , [AC_DEFINE(NO_GETTOD, 1, [Do we have gettimeofday()?])])
+AC_CHECK_FUNC(gettimeofday,[],[
+ AC_DEFINE(NO_GETTOD, 1, [Do we have gettimeofday()?])
])
AC_CACHE_CHECK([for gettimeofday declaration], tcl_cv_grep_gettimeofday, [
AC_EGREP_HEADER(gettimeofday, sys/time.h,