summaryrefslogtreecommitdiffstats
path: root/unix/configure.in
diff options
context:
space:
mode:
authorandreas_kupries <akupries@shaw.ca>2006-09-12 22:52:08 (GMT)
committerandreas_kupries <akupries@shaw.ca>2006-09-12 22:52:08 (GMT)
commit481c3e966dec813f857ea8fe0608e4f46c46a606 (patch)
treeb2447f62f43e94549c64f35e6855d2f5bac7e582 /unix/configure.in
parentb45164f6b072a2793e896f53449f81ba6f73f981 (diff)
downloadtcl-481c3e966dec813f857ea8fe0608e4f46c46a606.zip
tcl-481c3e966dec813f857ea8fe0608e4f46c46a606.tar.gz
tcl-481c3e966dec813f857ea8fe0608e4f46c46a606.tar.bz2
* unix/configure.in (HAVE_MTSAFE_GETHOST*): Modified to recognize
HP-UX 11.00 and beyond as having mt-safe implementations of the gethost functions. * unix/configure: Regenerated, using autoconf 2.13
Diffstat (limited to 'unix/configure.in')
-rw-r--r--unix/configure.in9
1 files changed, 8 insertions, 1 deletions
diff --git a/unix/configure.in b/unix/configure.in
index 0040c3d..4a3b7ae 100644
--- a/unix/configure.in
+++ b/unix/configure.in
@@ -3,7 +3,7 @@ dnl This file is an input file used by the GNU "autoconf" program to
dnl generate the file "configure", which is run during Tcl installation
dnl to configure the system for the local environment.
#
-# RCS: @(#) $Id: configure.in,v 1.106.2.30 2006/09/08 11:15:13 vasiljevic Exp $
+# RCS: @(#) $Id: configure.in,v 1.106.2.31 2006/09/12 22:52:10 andreas_kupries Exp $
AC_INIT(../generic/tcl.h)
AC_PREREQ(2.13)
@@ -158,6 +158,13 @@ if test "${TCL_THREADS}" = 1; then
# from the TSD instead of the static storage.
AC_DEFINE(HAVE_MTSAFE_GETHOSTBYNAME)
AC_DEFINE(HAVE_MTSAFE_GETHOSTBYADDR)
+ elif test "`uname -s`" = "HP-UX" && \
+ test "`uname -r|sed -e 's|B\.||' -e 's|\..*$||'`" -gt 10; then
+ # Starting with HPUX 11.00 (we believe), gethostbyX
+ # are actually MT-safe as they always return pointers
+ # from TSD instead of static storage.
+ AC_DEFINE(HAVE_MTSAFE_GETHOSTBYNAME)
+ AC_DEFINE(HAVE_MTSAFE_GETHOSTBYADDR)
else
SC_TCL_GETHOSTBYNAME_R
SC_TCL_GETHOSTBYADDR_R