summaryrefslogtreecommitdiffstats
path: root/unix/configure.in
diff options
context:
space:
mode:
authordas <das>2004-11-19 06:29:23 (GMT)
committerdas <das>2004-11-19 06:29:23 (GMT)
commit6297311b712fb631b245f682cfcbc17a233d7b60 (patch)
treea308ab4415be70ba2d96ac4b00d0aef89dbd9fdb /unix/configure.in
parent318ca631dc34f11954febc6e0681081c82365e46 (diff)
downloadtcl-6297311b712fb631b245f682cfcbc17a233d7b60.zip
tcl-6297311b712fb631b245f682cfcbc17a233d7b60.tar.gz
tcl-6297311b712fb631b245f682cfcbc17a233d7b60.tar.bz2
* macosx/Makefile:
* unix/configure.in: * unix/tclUnixInit.c (MacOSXGetLibraryPath): changed detection of tcl framework build when determining tclLibPath from overloaded TCL_LIBRARY to configuration define TCL_FRAMEWORK. [Bug 1068088] * unix/configure: autoconf-2.13 * tests/unixInit.test (7.1): fixed failure when running tests with -tmpdir arg not set to working dir.
Diffstat (limited to 'unix/configure.in')
-rw-r--r--unix/configure.in3
1 files changed, 2 insertions, 1 deletions
diff --git a/unix/configure.in b/unix/configure.in
index 6c4df56..bc91be2 100644
--- a/unix/configure.in
+++ b/unix/configure.in
@@ -3,7 +3,7 @@ dnl This file is an input file used by the GNU "autoconf" program to
dnl generate the file "configure", which is run during Tcl installation
dnl to configure the system for the local environment.
#
-# RCS: @(#) $Id: configure.in,v 1.106.2.10 2004/11/18 02:07:09 rmax Exp $
+# RCS: @(#) $Id: configure.in,v 1.106.2.11 2004/11/19 06:29:25 das Exp $
AC_INIT(../generic/tcl.h)
AC_PREREQ(2.13)
@@ -471,6 +471,7 @@ if test "$FRAMEWORK_BUILD" = "1" ; then
TCL_BUILD_LIB_SPEC="-F`pwd` -framework Tcl"
TCL_LIB_SPEC="-framework Tcl"
TCL_LIB_FILE="Tcl"
+ AC_DEFINE(TCL_FRAMEWORK)
elif test "$SHARED_BUILD" = "0" || test "$TCL_NEEDS_EXP_FILE" = "0"; then
if test "${TCL_LIB_VERSIONS_OK}" = "ok"; then
TCL_LIB_FLAG="-ltcl${TCL_VERSION}\${TCL_DBGX}"