summaryrefslogtreecommitdiffstats
path: root/unix/configure.in
diff options
context:
space:
mode:
authorpatthoyts <patthoyts@users.sourceforge.net>2010-07-11 16:12:43 (GMT)
committerpatthoyts <patthoyts@users.sourceforge.net>2010-07-11 16:12:43 (GMT)
commit7abfdd1acbbaf999810374d70a5b9423b898fb00 (patch)
treea26370ed1172ebe8e54b43453b6f446a4fe6d0d5 /unix/configure.in
parent1d8a79987fd062bf83f82fb9bc229e7b0e410606 (diff)
downloadtcl-7abfdd1acbbaf999810374d70a5b9423b898fb00.zip
tcl-7abfdd1acbbaf999810374d70a5b9423b898fb00.tar.gz
tcl-7abfdd1acbbaf999810374d70a5b9423b898fb00.tar.bz2
Use SC_PROG_TCLSH to set a native tclsh in the Makefile.
When installing the libraries a native tcl interpreter is used to process some files. The makefile uses NATIVE_TCLSH for this. This patch causes us to prefer an installed tclsh over the build product which solves build issues when cross-compiling (provided a native tcl is installed). If there is no native version, just try using the build product.
Diffstat (limited to 'unix/configure.in')
-rw-r--r--unix/configure.in13
1 files changed, 12 insertions, 1 deletions
diff --git a/unix/configure.in b/unix/configure.in
index 0ff790f..3752f6f 100644
--- a/unix/configure.in
+++ b/unix/configure.in
@@ -3,7 +3,7 @@ dnl This file is an input file used by the GNU "autoconf" program to
dnl generate the file "configure", which is run during Tcl installation
dnl to configure the system for the local environment.
#
-# RCS: @(#) $Id: configure.in,v 1.212 2010/04/30 21:15:42 dgp Exp $
+# RCS: @(#) $Id: configure.in,v 1.213 2010/07/11 16:12:45 patthoyts Exp $
AC_INIT([tcl],[8.6])
AC_PREREQ(2.59)
@@ -133,6 +133,17 @@ LIBS="$LIBS$THREADS_LIBS"
SC_ENABLE_SHARED
+#--------------------------------------------------------------------
+# Look for a native installed tclsh binary (if available)
+# If one cannot be found then use the binary we build (fails for
+# cross compiling). This is used for NATIVE_TCLSH in Makefile.
+#--------------------------------------------------------------------
+
+SC_PROG_TCLSH
+if test "$TCLSH_PROG" = ""; then
+ TCLSH_PROG='./${TCL_EXE}'
+fi
+
#------------------------------------------------------------------------
# Add stuff for zlib
#------------------------------------------------------------------------