summaryrefslogtreecommitdiffstats
path: root/unix/configure.in
diff options
context:
space:
mode:
authorKevin B Kenny <kennykb@acm.org>2008-03-30 04:26:15 (GMT)
committerKevin B Kenny <kennykb@acm.org>2008-03-30 04:26:15 (GMT)
commite5f1969c3350cce0f8cac276147a55961f9418d4 (patch)
treed371ccb1926cceb68ac8480d22ead45c57e7f3b4 /unix/configure.in
parent0c13b42b7fd7d214470460a9d63384166982ab11 (diff)
downloadtcl-e5f1969c3350cce0f8cac276147a55961f9418d4.zip
tcl-e5f1969c3350cce0f8cac276147a55961f9418d4.tar.gz
tcl-e5f1969c3350cce0f8cac276147a55961f9418d4.tar.bz2
* generic/tclInt.h (TclIsNaN):
* unix/configure.in: Added code to the configurator to check for a standard isnan() macro and use it if one is found. This change avoids bugs where the test of ((d) != (d)) is optimized away by an overaggressive compiler. [Bug 1783544] * unix/configure: autoconf-2.61
Diffstat (limited to 'unix/configure.in')
-rw-r--r--unix/configure.in14
1 files changed, 13 insertions, 1 deletions
diff --git a/unix/configure.in b/unix/configure.in
index 82e68da..320930a 100644
--- a/unix/configure.in
+++ b/unix/configure.in
@@ -3,7 +3,7 @@ dnl This file is an input file used by the GNU "autoconf" program to
dnl generate the file "configure", which is run during Tcl installation
dnl to configure the system for the local environment.
#
-# RCS: @(#) $Id: configure.in,v 1.180 2008/03/28 17:31:47 dgp Exp $
+# RCS: @(#) $Id: configure.in,v 1.181 2008/03/30 04:26:20 kennykb Exp $
AC_INIT([tcl],[8.5])
AC_PREREQ(2.59)
@@ -492,6 +492,18 @@ SC_ENABLE_LANGINFO
AC_CHECK_FUNCS(chflags)
#--------------------------------------------------------------------
+# Check for support of isnan() function or macro
+#--------------------------------------------------------------------
+
+AC_CACHE_CHECK([isnan], tcl_cv_isnan, [
+ AC_TRY_LINK([#include <math.h>], [
+isnan(0.0); /* Generates an error if isnan is missing */
+], tcl_cv_isnan=yes, tcl_cv_isnan=no)])
+if test $tcl_cv_isnan = no; then
+ AC_DEFINE(NO_ISNAN, 1, [Do we have a usable 'isnan'?])
+fi
+
+#--------------------------------------------------------------------
# Darwin specific API checks and defines
#--------------------------------------------------------------------